App Service Certification - Domain Validation doesnt work

Philipp Gerber 251 Reputation points
2022-05-11T09:52:20.827+00:00

Hey Community,

i have some Problems with the Domain Validation for an App Serice Certification at Azure.
I have create an TXT Record at the Domain and have wait for 4 to 5 hours.

But allways the same error on the Azure Portal.

200926-image.png

The Validation doesnt work.

I cant use a other Validation Option, so i must use this.

i have send me the E-Mail Instructions and when i use the link at this E-Mail i can see that the Certificate is successfully verified completed.

200993-image.png

I must really fast use this Certificate. How long i must wait, that i can use this Certificate at Azure Portal?

Thanks for the Answer.

Regards,
Phil

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,351 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Ryan Hill 26,951 Reputation points Microsoft Employee
    2022-05-11T20:26:20.217+00:00

    Hi @PhilippGerber-6516,

    Let's go through Troubleshoot domain and TLS/SSL certificate problems in Azure App Service first so we can nail down the issue you're having. Sounds like you can't validate your host name so let's make sure your TXT records are configured correctly. You'll need a TXT | @ | <app-name>.azurewebsites.net. If you already have that record, try manually verifying your domain. Comment down below none of this worked for you.

    With regards to binding the certificate, is managed or 3rd party? Are you using a wildcard or apex? Do you see any errors on the Certificate Binding Operation Detector, under Diagnose and solve problems blade?

    201139-image.png


  2. Philipp Gerber 251 Reputation points
    2022-05-16T13:04:15.96+00:00

    I have opened a Ticket on Microsoft Support.

    The Problem was the Name of the Domain. Azure was in the Name and GODADDY have blacklistet all Names with contains "Azure".

    MS have talked with Godaddy and have whitelistet the Domain.

    0 comments No comments