question

AlezpcTechnique-0353 avatar image
0 Votes"
AlezpcTechnique-0353 asked SumanthMarigowda-MSFT edited

Can't connect to Azure Storage with Azure AD Account

Hi,
I have a problem to connect an Azure File storage on my computer with my account Azure AD (toto@myAzureDom.com)

my compuer runs under Win10 Pro
my computer is attached to my Azure AD DS domain
I have an AZURE VPN and is it connected
I can map a network drive to Azure Storage with my Auth key
but when i try to map it with my credentials, it returns "wrong password" (but my password is OK : it's my loging on the computer and for the VPN)

Can you help me ?
Regards
Vincent FRANCOIS





azure-storage-accounts
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SaiKishor-MSFT avatar image
0 Votes"
SaiKishor-MSFT answered SaiKishor-MSFT edited

@AlezpcTechnique-0353 Thank you for reaching out to Microsoft Q&A. I understand that you are having issues with Azure File Storage where when you enter the password, it returns "wrong password" although it is right on your computer.

Please refer to a similar thread discussed here- https://docs.microsoft.com/en-us/answers/questions/290947/network-password-incorrect-using-azure-ad-ds-ident.html

As discussed, this happens due to the Synchronization setting on the AAD DS. It has to be set to ALL not Scoped.
It's under the Synchronization settings menu for Azure AD Domain Services. You can then change the scope from 'Scoped' to 'All'.

Please try enabling this and see if that helps with the error. Let us know if you have any further questions and we will be glad to assist you further. Thank you!

Remember:

Please accept an answer if correct. Original posters help the community find answers faster by identifying the correct answer. Here is how.

Want a reminder to come back and check responses? Here is how to subscribe to a notification.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AlezpcTechnique-0353 avatar image
0 Votes"
AlezpcTechnique-0353 answered SaiKishor-MSFT edited

Hi,
Thanks for your answer !
But... Synchro setting is already set to "ALL"
Regards

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@AlezpcTechnique-0353

Please see if the below helps:

"One other thing I have found that gives the same experience is that you need to allow the RC4 cypher. If you have deployed CIS benchmarks Level 1 for AD in the domain it will disable RC4 and cause this issue too. It is noted here https://docs.microsoft.com/en-us/azure/storage/files/storage-files-identity-auth-active-directory-domain-service-enable"

In the meanwhile, I will check with the security team regarding this further. Thank you!

0 Votes 0 ·
SaiKishor-MSFT avatar image
0 Votes"
SaiKishor-MSFT answered

@AlezpcTechnique-0353 After some discussion with the Security team, here are few more things that you can try:

Hope this helps. Please let us know if you have any further questions and we will be glad to assist you further. Thank you!

Remember:

Please accept an answer if correct. Original posters help the community find answers faster by identifying the correct answer. Here is how.

Want a reminder to come back and check responses? Here is how to subscribe to a notification.



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.