TLS issue, unable to config tls 1.2 with .net 4.7.2 application

vidya v 1 Reputation point

We have our application in .net framework 4.0 and 4.7.2.

when we host in IIS and run it, we are getting error in client side (Your TLS security settings aren’t set to the defaults, which could also be causing this error) with https access.

We need our application to use tls1.2 by default by disabling other tls versions.

please help.

ASP.NET Web Forms
ASP.NET Web Forms
A part of the ASP.NET web application framework that can be used to create ASP.NET web applications.
408 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Lan Huang-MSFT 9,281 Reputation points Microsoft Employee

    Hi @vidya v ,

    Your TLS security settings aren’t set to the defaults, which could also be causing this error

    To Fix your TLS security settings aren’t set to the defaults follow these easy steps:

    1. Navigate to Run by holding Windows+R Keys.
    2. Type Control and press Enter.
    3. Click on Internet Options.
    4. Click on Advanced Tab, Scroll down and navigate to TLS Options.
    5. Restart your browser and check. if same problem is persisted then Follow step-2.

    You can refer to this post.

    There are three tasks for enabling TLS 1.2 on clients:

    • Update Windows and WinHTTP.
    • Ensure that TLS 1.2 is enabled as a protocol for SChannel at the operating system level.
    • Update and configure the .NET Framework to support TLS 1.2(For TLS 1.2, target .NET Framework 4.7 or later on your application).
      It is better to add the following in web.config: <httpRuntime targetFramework="4.7.2" />

    You can refer to these documents.
    How to enable TLS 1.2 on clients
    Transport Layer Security (TLS) best practices with the .NET Framework
    Best regards,
    Lan Huang

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments