question

juanmaximilianoaguilarabanto-6444 avatar image
0 Votes"
juanmaximilianoaguilarabanto-6444 asked YijingSun-MSFT commented

Error in ScriptResource - WEB Forms - Aspnet 4.5

Hi
A friend migrated an web site from aspnet 2.0 to aspnet 4.5.
The project has toolscriptmanager. The web sites doesn't work because I can see that there is a same front end error.

204142-image.png


dotnet-aspnet-webforms
image.png (98.1 KiB)
· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @juanmaximilianoaguilarabanto-6444 ,
Could you post your web.comfig to us? It may help us to solve your problems.
Best regards,
Yijing Sun

0 Votes 0 ·
juanmaximilianoaguilarabanto-6444 avatar image juanmaximilianoaguilarabanto-6444 juanmaximilianoaguilarabanto-6444 ·

Hello
This is thi file.
Thanks

0 Votes 0 ·

Any chance you using the ajaxtoolkit? If yes, then I suggest you upgrade. It for a good number of years used it own script manager. But, that was messy, and now the ajaxtoolkit uses the standard script manager (you don't need two of them). This comment is just a FYI, since it quite bit better to have only one script manager in your application as opposed to several, or in this case two of them as was the case in the past for the ajaxtoolkit.

If you not using the ajaxtoolkit, then you can ignore this post - but the information is still of use in case others come across this issue.

0 Votes 0 ·
surferonwww avatar image
0 Votes"
surferonwww answered surferonwww edited

Can the following article help?

ASP.NET 4.5 ScriptManager Improvements in WebForms
https://devblogs.microsoft.com/dotnet/asp-net-4-5-scriptmanager-improvements-in-webforms/

In ASP.NET 4.5 or later version, for the server controls which use client script to work properly, the required scripts need to be registered to the ScriptManager and the pages should include the ScriptManger.

[Edit (added)]

See the following article if you use the Ajax Control Toolkit.

How to Use Bundling and CDN
https://github.com/DevExpress/AjaxControlToolkit/wiki/How-to-use-bundling-and-CDN

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

YijingSun-MSFT avatar image
0 Votes"
YijingSun-MSFT answered YijingSun-MSFT commented

Hi @juanmaximilianoaguilarabanto-6444 ,
You could try to do this:
replace:

   <add verb="GET" path="ScriptResource.axd" type="Microsoft.Web.Handlers.ScriptResourceHandler" validate="false"/>

to:

 <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="False"/>

Best regards,
Yijing Sun


If the answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our  documentation  to enable e-mail notifications if you want to receive the related email notification for this thread.

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi
I have the same error after I changed that

0 Votes 0 ·
YijingSun-MSFT avatar image YijingSun-MSFT juanmaximilianoaguilarabanto-6444 ·

Hi @juanmaximilianoaguilarabanto-6444 ,
"404" could also mean (under certain conditions) a "Not enabled" or "not allowed". I had that some time back on a server and had to enable some extension.
Another way would be to use Process Monitor to see whether real files are being searched by the IIS process and not found.

Best regards,
Yijing Sun

0 Votes 0 ·

Hi
We have the error in IIS Express and in IIS

0 Votes 0 ·
Show more comments