question

EvgeniyGoldshtein-8572 avatar image
0 Votes"
EvgeniyGoldshtein-8572 asked KyleXu-MSFT commented

OU list is empty when adding new user or group

We have Exchange 2016 CU22
When trying to choose OU while creating anew user or group, I'm getting the blank screen with "There are more results..." and "there are no items...".
The issue itself is familiar. We have more then 500 OUs, so <add key="GetListDefaultResultSize" value="5000" /> was added a few years ago.

After May updates, as usual, this line disappeared from the C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\ecp\web.config
It happens after every Exchange update, so as usually I added it again on all servers. But his time it did not help!
I tried removing it, re-adding it, changing the number, restarting ECP pool and IIS - nothing.

I also saw a solution for Exchange 2013 to add the same line to C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\ecp\web.config, but in my case I gott 502 error and ECP didn't work at all until I removed it.

Any Ideas, guys?

office-exchange-server-administration
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@EvgeniyGoldshtein-8572

Gald to see this issue is solved now. Due to the update of policy, the question author cannot accept their own answer. They can only accept answers by others.
If you could, you accept the summary below as an answer to close this thread. It also could be beneficial to other community members reading this thread.

0 Votes 0 ·
KyleXu-MSFT avatar image
0 Votes"
KyleXu-MSFT answered KyleXu-MSFT commented

@EvgeniyGoldshtein-8572

It happens after every Exchange update, so as usually I added it again on all servers. But his time it did not help!

From this article, we can know that this is expected behavior you need to add this value every time that you install a cumulative update.

I suggest you use the command below to check the number of OU in your organization. Then use a use a close value in the configure file. Such as using 510, if there exist 500 OU in your AD.

 (Get-OrganizationalUnit -ResultSize unlimited).count

If it doesn't work for your Exchange server, I would suggest you update it to the latest version Exchange Server 2016 CU23 + May22SU: This value could work in this CU (I set this value to 1)

205587-qa-kyle-09-50-13.png


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I also tested it with 513 OU, it could works

205662-qa-kyle-10-18-39.png


0 Votes 0 ·
EvgeniyGoldshtein-8572 avatar image
0 Votes"
EvgeniyGoldshtein-8572 answered

@KyleXu-MSFT As I said, we do have more then 500 OUs and used this web.config trick for years, it just stopped working.

Anyway, I found the problem: After the last update when I copy/pasted the line into web.config on all servers, I didn't copy it right on 1 of them (out of 10). I'm not sure why all the servers were affected, but after correcting it it started to work!

Thanks everyone!

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KyleXu-MSFT avatar image
0 Votes"
KyleXu-MSFT answered KyleXu-MSFT edited

@EvgeniyGoldshtein-8572

Yes, you need to change it for all Exchange servers. I noticed you said "I added it again on all servers", so I didn't mention this one in the first step of troubleshooting.

When you login EAC from Exchange server A, this request may be redirected to another Exchange server (as far as I know, it effected by the DNS record and where your admin account hosted) , so you need to change this one on all Exchange servers.


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.