Linux agent install issue

Berg, Ronald van den 46 Reputation points
2022-06-02T05:45:11.353+00:00

On a few new redhat 7.9 servers i cannot install a scom agent.
The error is: WinRM cannot complete the operation...etc
This normally indicates that port 1270 is blocked in the network or on the node, but in this case it isn't.

When i monitor the traffic with wireshark i only see traffic from the gateway to the linux server on port 1270.
Of course there's no listener process yet on that port so it will fail.
I'm expected to also see traffic on port 22 but nothing like that.
I verified that the user and credentials work and both ports are open to the linux server.
Enabling debugging (EnableOpsMgrModuleLogging) doesn't show any issues.

Any ideas what this can be?

Our scom version is 2019ur3

Operations Manager
Operations Manager
A family of System Center products that provide infrastructure monitoring, help ensure the predictable performance and availability of vital applications, and offer comprehensive monitoring for datacenters and cloud, both private and public.
1,204 questions
No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Fursel 331 Reputation points
    2022-06-02T06:15:35.93+00:00

    Try to install Agent manually and see what will happen

    sh ./scx-<version>.rhel.<version>.<arch>.sh --install --enable-opsmgr

    No comments

  2. Berg, Ronald van den 46 Reputation points
    2022-06-02T06:32:47.07+00:00

    Fursel,
    That will probably work, but does not resolve my issue. With installing it that way i do not come closer to a solution.

    No comments

  3. Anonymous
    2022-06-02T07:36:20.53+00:00

    Hi Ronald,

    So you saw traffic on port 1270, but none on 22? Can it be that it is being blocked (firewall)?¨

    Can you please try what Roger suggested in the post below:

    Getting Error while putting unix servers under SCOM monitoring

    https://social.technet.microsoft.com/Forums/en-US/32bda371-e2c5-44e8-a305-ae7da886a2c8/getting-error-while-putting-unix-servers-under-scom-monitoring?forum=operationsmanagerunixandlinux

    winrm enumerate http://schemas.microsoft.com/wbem/wscim/1/cim-schema/2/SCX_Agent?__cimnamespace=root/scx -username:<Linux user> -password:<Linux Passwd> -r:https://<LInux system>:1270/wsman -auth:basic -skipCACheck -skipCNCheck -skiprevocationcheck -encoding:utf-8  
    
    If this works try running without the -skip* options:  
    
    winrm enumerate http://schemas.microsoft.com/wbem/wscim/1/cim-schema/2/SCX_Agent?__cimnamespace=root/scx -username:<Linux user> -password:<Linux Passwd> -r:https://<LInux system>:1270/wsman -auth:basic  -encoding:utf-8  
    

    According to this one:

    The target address is unreachable

    https://learn.microsoft.com/en-us/troubleshoot/system-center/scom/troubleshoot-unix-linux-agent-discovery#the-target-address-is-unreachable

    it is a port iossue with 1270...Have you ensure that the communication on port 1270 reaches the Linux endpoint?

    The following blog also suggests port connectivity issues and suggest running a simple port check:

    OpsMgr (SCOM) - Unix/Linux Agents Requisites and Troubleshooting

    http://syscentering.blogspot.com/2016/03/unixlinux-monitoringdiscovery-in-opsmgr.html

    Last, but not least:

    SCOM * nix Monitoring: The WinRM client cannot process the request because the server name cannot be resolved*
    http://www.opsman.co.za/scom-nix-monitoring-the-winrm-client-cannot-process-the-request-because-the-server-name-cannot-be-resolved/

    Hope somewhere on the way you will find what is wrong.


    (If the reply was helpful please don't forget to upvote or accept as answer, thank you)
    Regards,
    Stoyan

    No comments

  4. Berg, Ronald van den 46 Reputation points
    2022-06-03T10:16:37.917+00:00

    Stoyan, thanks for thinking with me.

    No ports are not blocked and tested, and even if port 22 is blocked i would see an attempt in wireshark to connect to that port and there's nothing on 22.

    Running winrm queries is not usefull since there's no agent installed, hence no listener process on the winrm port 1270.

    I did tried the option with a shorter password, same result so it must be something else, i'll reach out to support.

    No comments