Azure AD Connect – Sync Errors after local server would not boot.

Jeremy Fontenot 1 Reputation point
2022-06-07T01:23:44.203+00:00

Hybrid Environment: Microsoft Server 2019, Microsoft 365, Azure Active Directory.

Initial start-up Microsoft 365 users added on-prem server OS Server 2019 and connected to Azure services. Server 2019 no boot and reinstalled the OS, ADDS. Now when trying to add on-prem users receive a sync error for duplicate attribute UserPrincipalName, and an additional user is created. Could someone please guide me on how to resolve sync errors in Azure AD Connect and Microsoft 365 Admin center when adding users back to the on-prem server?

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
2,201 questions
Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
12,702 questions
No comments
{count} votes

3 answers

Sort by: Most helpful
  1. T. Kujala 8,421 Reputation points
    2022-06-07T05:01:14.333+00:00
    No comments

  2. Limitless Technology 37,351 Reputation points
    2022-06-08T07:27:26.507+00:00

    Hi there,

    I would suggest you have a look at the directory synchronization errors in Microsoft 365 to troubleshoot it further. You can view directory synchronization errors in the Microsoft 365 admin center. Only the User object errors are displayed.

    View directory synchronization errors in Microsoft 365 https://learn.microsoft.com/en-us/microsoft-365/enterprise/identify-directory-synchronization-errors?view=o365-worldwide

    Here is a link that has some additional troubleshooting steps which you can try and see if helps in overcoming your issue. Understanding errors during Azure AD synchronization https://learn.microsoft.com/en-us/azure/active-directory/hybrid/tshoot-connect-sync-errors

    Fixing problems with directory synchronization for Microsoft 365 https://learn.microsoft.com/en-us/microsoft-365/enterprise/fix-problems-with-directory-synchronization?view=o365-worldwide

    Troubleshoot object synchronization with Azure AD Connect sync https://learn.microsoft.com/en-us/azure/active-directory/hybrid/tshoot-connect-objectsync

    ------------------------------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept it as an answer–

    No comments

  3. Nick Von Ogden 26 Reputation points
    2022-06-09T05:59:35.187+00:00

    hard to tell without more details, and also to clarify, do you mean 'new users', in that you are creating new on prem users, and they are not syncing or 'existing' users in your on prem environment and it's a 'new sync' and those existing users aren't properly syncing? It sounds like it's possible you have orphaned users in Azure AD now.