ARM Template - Az104004-Lab-Configuring NSG

Riyaz 66 Reputation points
2022-06-08T08:26:47.12+00:00

Hi There,

I am a newbie to this forum, please do not mind, if my question may seem silly.

Past a week, I have been trying to workout a lab course for Az-104 certification, however, in one of the github quick start lab asked to use ARM templates where I do not have much idea about it. Although, spent little time in youtube and try to figure out how to write Json code for TemplateFile as well as TemplateParameter. Its all set to execute after preliminary checks, though I stuck in middle of running code through cloudshell and getting following error.

Error: Code=InvalidDeployment; Message=The deployment 'az104-04-vms-loop-template' must have either the TemplateLink or Template property set.

I would request any of forum members to help me out to fix it out, that would be really helpful.

Regards
RM.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
23,768 questions
{count} votes

Accepted answer
  1. msrini-MSFT 5,676 Reputation points Microsoft Employee
    2022-06-08T15:15:57.867+00:00

    Can you try to open portal and search for "Deploy a custom Template" ?

    Then click on Build your own template and copy paste the content of your lab files to this template and then deploy it .

    Let me know if that works.

    Regards,
    Karthik Srinivas


1 additional answer

Sort by: Most helpful
  1. Dave Patrick 329.1K Reputation points Microsoft MVP
    2022-06-08T14:02:51.283+00:00

    Microsoft Certification Program is supported on their own forums. I'd try asking for help with course issues in dedicated forums here. (Participate\Ask A Question)
    Courses and Course Content/Course Content Issue
    Troubleshooting known issues
    Content Reporting

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    No comments