Windows 11 22H2 Broke custom virtual switches in Hyper-V

Erik Read 86 Reputation points

I upgraded my Windows 11 physical machine to 22H2 this morning. This machine hosts 4 hyper-v virtual machines using 2 different virtual switches. 1 switch is an internal NAT and the other a bridged external.
Up until the upgrade these switches performed flawlessly.
After the upgrade, no internet connectivity from either switch.

I did add a third NIC to one of the VMs and pointed it to the default switch and it works but that is not what I need, nor would I consider that a valid alternative.

Any information I can provide I will be happy to.

System Center Virtual Machine Manager
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,372 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
6,796 questions
{count} votes

Accepted answer
  1. Sarah Tennyson 126 Reputation points

    I had this same problem, with a bit of flailing around I was able to correct it... what I did:

    Changed all my VMs to use another v-switch.
    Deleted the v-switch that wasn't working.
    Went into the properties of the external network adapter and unchecked "Hyper-V Extensible Virtual Switch"
    Re-created the v-switch using the external network adapter
    Changed all the VMs to point to the re-created v-switch.

    Solved my problem.... hope it helps you.

    10 people found this answer helpful.

8 additional answers

Sort by: Most helpful
  1. Erik Read 86 Reputation points

    One other way I figured out how to fix was to go into each virtual switch and in the virtual switch manager expand the + next to each. This exposes the Extensions property. For me there are 3 extensions, Microsoft Windows Filtering Platform, Microsoft Azure VFP Switch Filter Extension, and Microsoft NDIS Capture. Of those, the last 2 were enabled and the the last one, Microsoft NDIS Capture was throwing an error. I disabled both enabled extensions and it all started working again.
    My guess is that recreating the switches as @Sarah Tennyson did essentially corrected the error the older switches were having.

    8 people found this answer helpful.

  2. O. Lohkamp 11 Reputation points

    I just deleted and re-created the external virtual switch.

    2 people found this answer helpful.

  3. Sergio Acuña 6 Reputation points

    I had the same issue on my setup. Unfortunately, none of the above worked. Also tried to recreate the v-switch, had unchecked the "Hyper-V Extensible Virtual Switch" option, removed the Microsoft Windows Filtering Platform & Microsoft Azure VFP Switch Filter Extension, none worked.
    Had to rollback to previous version.
    But one important thing about this. When I first updated to 22H2, hyper-v gave me the option to "upgrade" the vm's to new configuration, which I did (my bad).
    When did the rollback, the "old" hyper-v did not recognize any of the VM... I had to manually delete the configuration files, remove the vm's using powershell, and then recreate the VM's attaching the disk files.

    1 person found this answer helpful.
    0 comments No comments

  4. O. Lohkamp 11 Reputation points

    Sometimes, also deleting the physical network card in device manager helps. Then let it search for new hardware and install the driver with default settings.
    Good luck.