SSIS flexible file source Java SE is required to use ORC format

DAITHI 1 Reputation point
2020-09-07T21:36:53.233+00:00

Hi
I am trying to read orc files so that I can take the data from them and load into a sql database.
I am using the SSIS package that was an addition to SSDT and its an azure addon (SSIS AZURE Feature pack https://learn.microsoft.com/en-us/sql/integration-services/azure-feature-pack-for-integration-services-ssis?view=sql-server-ver15 ) called flexible file source.

But every time I use the format as ORC files and give it a folder and file I get the message 'java se is required to use orc/parquet format'....
So I follow the instructions here and install oracle java se (https://learn.microsoft.com/en-us/sql/integration-services/azure-feature-pack-for-integration-services-ssis?view=sql-server-ver15#dependency-on-java)
So I then run the ssdt I made with a data flow to connect flexible file source and I keep getting the same error............I have tried a few versions of java se and none seem to work...........I keep getting the error..........I have tried in 32 and 64 bit versions.
All help appreciated.

SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
1,860 questions
SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
8,591 questions
No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Monalv-MSFT 5,686 Reputation points
    2020-09-08T07:04:21.8+00:00

    Hi DAITHI,

    Could you please share more error messages?

    Please refer to the following links:
    Flexible File Source
    Flexible File Task
    SQL Server Integration Services Flexible File System Task with Azure Blob Storage

    Best Regards,
    Mona

    ----------

    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  2. DAITHI 1 Reputation point
    2020-09-08T08:00:59.123+00:00

    Hi Mona
    That is the full error I get albeit the message also refers to a Web link of which I have added as the second link in my original question.
    I cannot even begin the run the ssis package as soon as I click on the columns tab......the message comes up.....i will add a screen shot later.....


  3. DAITHI 1 Reputation point
    2020-09-09T14:49:37.817+00:00

    Here is a screen shot of whats setup and the error message..............

    23555-image.png


  4. Pascal Hasler 1 Reputation point
    2020-10-14T14:26:20.527+00:00

    I get the same error after installing Oracle SE runtime. Putting the mouse over the red x shows the message: Column mapping is missing

    No comments

  5. Pascal Hasler 1 Reputation point
    2020-10-14T15:10:29.927+00:00

    The solution was that after installing Oracle Java 8u192, you have to follow the instructions of the Zulu JDK installation:

    1. Download and extract the installation zip package.
    2. From the Command Prompt, run sysdm.cpl.
    3. On the Advanced tab, select Environment Variables.
    4. Under the System variables section, select New.
    5. Enter JAVA_HOME for the Variable name.
    6. Select Browse Directory, navigate to the extracted folder, and select the jre subfolder. Then select OK, and the Variable value is populated automatically.
    No comments