Can't RDP

Hussain Gurain 1 Reputation point
2022-06-12T16:14:55.337+00:00

I tried to connect to a server using Remote desktop connection, it takes around 1 minute trying to connect then it fails. I get the error 0x904.

I tried switching from vDSL internet connection to my phone's internet 5g, and the remote desktop connection was successful. So why can't I connect using my internet home vDSL?

210578-image.png

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
3,054 questions
No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Marc Imhof 1 Reputation point
    2022-06-12T16:30:41.607+00:00

    Hi...if that is not a connectivity issue, like bandwidth constraints, check if just using Ip address works. Also...check if bitdefender is getting in the way...if so add an exception.

    No comments

  2. Hussain Gurain 1 Reputation point
    2022-06-12T20:31:27.823+00:00

    It didnt work

    No comments

  3. Marc Imhof 1 Reputation point
    2022-06-13T12:52:17.29+00:00

    Hi...on your home vDSL, did you open up the ports required to RDP? Maybe see if TCP 3389 is blocked right now - and open it up.

    No comments

  4. Hussain Gurain 1 Reputation point
    2022-06-14T21:42:25.987+00:00

    I tried opening a port for RDP on my vDSL, even though i dont see how its related, because im not trying to connect to my computer, im trying to connect to a cloud server, which i also tried opening a port from the cloud server, and it didn't work. I also changed the port number from 3389 from the server to 3320 and 1350 to test from the registry. I was able to connect for 1 second and then i was disconnected and was never able to connect again. I don't know how to solve it.

    Edit:
    I checked from PortCheckTool for 3389 port and it says its open

    No comments