VS 2017 Community Clean Install Remains Locked to Stale License Holder

SunMesa 31 Reputation points
2022-06-12T23:58:54.967+00:00

Hello all, brand new here-

I recently launched VS 2017 Community Edition, v15.9.21, on Windows 7 Home Premium 64-bit, which brought up a dialog box saying that my license had gone 'stale' and needed updating.

The notice also said that the installation of VS was licensed to an email address that actually no longer exists. I nevertheless tried signing in with it from the dialog box, also tried "look for updated licenses", both without success. So, I created a new Microsoft account tied to my new email address, the same one that I successfully used to register with on this forum.

I noticed that the current installation was not the most recent, so I performed a very thorough uninstall, first using the VS installer interface, then following that with InstallCleanup with argument -f, and finally, manually deleted every trace of VS 2017 that I could find from the registry, along with various caches still lingering in AppData/Local, etc.

I then downloaded and installed v15.9.48. This was an offline install, as was the previous version. By all appearances, the installation was successful.

However, upon launching the new installation, I still get the stale license notice, and it still insists that the license holder is the obsolete email address! None of the available links ("Sign in" or "Check for an updated license") in the dialog box work, using either of the obsolete or current email addresses and their corresponding passwords.

How in the world can this new install remain linked to the 'stale' license holder after the above procedure? Where is this information being stored, and how do I delete/reset it?

At this point I'm dead in the water, and desperately need to get VS up and running again. Thanks so much for any insight or assistance!

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
2,402 questions
Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
695 questions
No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Anna Xiu-MSFT 11,021 Reputation points Microsoft Employee
    2022-06-13T03:32:54.35+00:00

    Hi @SunMesa ,

    Welcome to Microsoft Q&A!

    Please have a try with the following steps:

    1. Sign out and close all running instances of Visual Studio
    2. Delete all files of %localappdata%.Identityservice and %localappdata%\Microsoft\VSCommon\OnlineLicensing\VisualStudio\15.0
    3. Relaunch your Visual Studio and sign in it with your new Microsoft account

    Sincerely,
    Anna
    *
    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  2. SunMesa 31 Reputation points
    2022-06-14T13:39:51.557+00:00

    Hi @Anna Xiu-MSFT , thanks for your feedback, and apologies for my delayed response. Further apologies for submitting this as an answer, rather than a comment to your answer... when I tried to do so, the "Submit" button did not function.

    I tried your suggestion. It did produce some progress... now when VS launches, the sign-up dialog box now says that the 30-day evaluation period has ended (rather than saying the license is stale).

    But after clicking "Sign in" link and entering the new email address and password, it shows "One moment..." for a while, then shows "Sorry, we ran into a problem. The underlying connection was closed: An unexpected error occurred on a send."

    The OnlineLicensing folder remained empty after this attempt, but there was a new .IdentityService folder created.

    In my previous google search investigation of this issue, there were some indications that the choice of default browser can produce this message. So, I went through the same sequence above using Microsoft Edge, Internet 11, Chrome, and Firefox as the default browser, all with the same result.

    I don't know if it's relevant, but when Chrome was the default browser, I additionally tried the "Check for updated license" link, and got the following curious message:
    "AADSTS165000: Invalid Request: The request tokens do not match the user context. One or more of the user context values (cookies; form fields; headers) were incorrect or invalid, these values should not be copied between requests or user sessions; always maintain the ALL of the supplied values across a complete single user flow. The request did not return all of the form fields. Failure Reasons:[Token is invalid;]"

    Thanks again for your suggestion, and any new ones you may have!


  3. SunMesa 31 Reputation points
    2022-07-01T00:49:17.557+00:00

    @Anna Xiu-MSFT ,

    Windows Defender is enabled, but there is no other 3rd-party anti-virus software running, nor is there any proxy server.

    Since your suggestion above to delete the .IdentityService and OnlineLicensing folders, the issue has now become how to activate the new installation of VS 2017... it no longer associates the installation with a stale license, it says the 30-day evaluation period has expired, and a sign-in is required to unlock the IDE. It's the sign-in that's failing.

    As such, the title of this post is probably no longer appropriate... it should be "VS 2017 Community Sign-In Not Functioning", and indeed I started a Microsoft Support ticket with that title. Just two days ago I went through an extensive screen-sharing session with two Microsoft reps who tried everything they could think of (too much to relate here), but at the end of it they remained completely baffled. It has been escalated to yet another team, I have yet to hear anything further.

    I will certainly update here if any resolution is found.

    No comments