Application Deployment/Install Failure

Blacksuit07 21 Reputation points
2022-06-13T20:32:32.89+00:00

Ok, so I have scoured the web for the answer but nothing I found is helping me find the issue...When deploying Notepad++ or Adobe Creative Cloud I get the following error in Software Center.

The software could not be found on any servers at this time.

AppEnforce log has the following:

+++ Starting Install enforcement for App DT "Adobe Creative Cloud - Acrobat Pro" ApplicationDeliveryType - ScopeId_D9F78E76-3F16-4906-B357-72D88B3184A4/DeploymentType_5d2b2e3d-122b-413c-8163-77f5614fa640, Revision - 4, ContentPath - C:\Windows\ccmcache\2, Execution Context - Any

Performing detection of app deployment type Adobe Creative Cloud - Acrobat Pro(ScopeId_D9F78E76-3F16-4906-B357-72D88B3184A4/DeploymentType_5d2b2e3d-122b-413c-8163-77f5614fa640, revision 4) for system.  

+++ Application not discovered. [AppDT Id: ScopeId_D9F78E76-3F16-4906-B357-72D88B3184A4/DeploymentType_5d2b2e3d-122b-413c-8163-77f5614fa640, Revision: 4]
App enforcement environment:
Context: Machine
Command line: msiexe /i "Adobe Acrobat.msi" /qn /l*v "C:\logs\AdobeInstall.txt"
Allow user interaction: No
UI mode: 1
User token: null
Session Id: 2
Content path: C:\Windows\ccmcache\2
Working directory: AppEnforce 6/13/2022 12:57:05 PM 3052 (0x0BEC)
Prepared working directory: C:\Windows\ccmcache\2
Invalid executable file msiexe
CMsiHandler::EnforceApp failed (0x87d01106).
AppProvider::EnforceApp - Failed to invoke EnforceApp on Application handler(0x87d01106).
CommenceEnforcement failed with error 0x87d01106.
Method CommenceEnforcement failed with error code 87D01106
++++++ Failed to enforce app. Error 0x87d01106. ++++++

When I run the installation via commandline it works with no issues. I have deployed Notepad++ several times in different iterations of SCCM and it is very aggravating that I am getting an error for something I have done before. Any insight would greatly be appreciated! I have a feeling it may be the detection method but it doesnt explain the "The software could not be found on any servers at this time." as I have not seen that before since working with SCCM since 2012. I have updated and verified the Client DP SCCM Certificate, Redistrubited the content on the DP, and confirmed my code via the commandline on a test machine. Some applications install just fine but these 2 are the latest failures....

Thanks.

Microsoft Configuration Manager
Microsoft Configuration Manager Application
Microsoft Configuration Manager Application
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Application: A computer program designed to carry out a specific task other than one relating to the operation of the computer itself, typically to be used by end users.
336 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Rahul Jindal [MVP] 6,331 Reputation points Microsoft MVP
    2022-06-13T21:22:59.167+00:00

    Well for start, the command line shared above appears be incorrect. It should be msiexec and there shouldn't be space before AdobeInstall. txt

    msiexe /i "Adobe Acrobat.msi" /qn /l*v "C:\logs\ AdobeInstall.txt"

    No comments

  2. Rita Hu -MSFT 9,401 Reputation points
    2022-06-16T08:25:38.25+00:00

    @Blacksuit07
    What is the Deployment Types of the application? What is the suffix of the application package? .exe or .msi

    Please help to confirm whether the .EXE application has been installed on the affected CM client or not. It will be better if you could provide the AppDiscovery.log and AppEnforce.log for reference in the affected CM client.

    As far as I know, the application package with .exe suffix is recommended to use the Script Installer deployment type.
    Please refer to the below screenshot to check the Deployment Types of your application.
    211978-1.png

    In addition, I tried to deploy the Notepad++ 4.8.2 in my lab and it seems that it worked successfully. I put my reference link for your reference.
    https://www.anoopcnair.com/sccm-script-deployment-type-using-powershell/

    Note that the link isn't from MS, just for your reference. We could also create a application manually on the MECM console instead of using the PowerShell script. I used the installation script and create the application manually in the MECM console. And It worked successfully.

    Hope the above will be helpful.

    Best regards,
    Rita


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments