Getting error that admin policies don't allow sharing with people outside, but the group I added is internal

Joe Grover 336 Reputation points
2022-06-14T20:21:09.643+00:00

We have been creating numerous Teams/SharePoint sites for different projects. We create links to these sites in a specific SharePoint site, and set the visibility of each link to be seen by whoever is on the project the link points to. For example if we have a Team called Project X with a SharePoint site of /sites/ProjectX, then we'll set the visibility of the link to only be seen by the Project X Team by clicking on the dots menu for the specific .lnk file, selecting Manage Access, and trying to add them to Direct Access.

Today when I went to do this however, I get an error indicating the following:

211434-image.png

I've not had this happen before. I don't get the error if I put in a user or security group, but I do if I select a Team. In fact, I get it if I select any Team--even one I've already granted to a different link. It also happens if I go back to one of my existing links and try to add another Team to view it. There are no external users in any of these Teams.

It's as if something changed so it thinks all of our Teams are external to the organization, but neither I nor the other admin have made any changes in the last few days. I did not have this problem last week when setting up these Teams.

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
1,457 questions
SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
6,033 questions
Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
5,332 questions
No comments
{count} votes

Accepted answer
  1. Yi Lu_MSFT 16,676 Reputation points Microsoft Employee
    2022-06-15T07:20:00.803+00:00

    Hi @Joe Grover
    I have reproduced your issue on my site. It seems that something could be wrong:

    211544-image.png

    As a workaround, if I grant permission to my Team through Manage access > Advanced > Grant Permissions, it will be OK:

    211593-image.png

    211603-image.png

    211587-image.png

    You could send feedback to Microsoft SharePoint Feedback to submit this question.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

1 additional answer

Sort by: Most helpful
  1. Joe Grover 336 Reputation points
    2022-06-16T13:03:22.663+00:00

    Perfect. I opened a support case with Microsoft yesterday and they confirmed this is an issue on their end and hopefully should have a fix soon. Using the Advanced settings as a workaround did the trick for me in the meantime. Thanks!

    No comments