APIM Capacity mysteriously and significantly increased

Aeschleman, Luke 21 Reputation points
2022-06-15T12:17:07.46+00:00

We've been running an API on the Standard Tier (2 units) for a little over a year now. We added a new API to the mix about 3 months ago, but otherwise there has been no change. However, last Friday our APIM capacity started spiking and consistently hit 100%.

Our requests, data transfer, and cache hits have all stayed consistent (in fact, they were higher throughout the work week than over the weekend).

We've adjusted out tier to Premium (1 unit) and capacity is now hovering around 40-50%.

We haven't seen any updates relating to APIM. There was routine maintenance for App Service East-US Friday morning at 2am, but the capacity increase started around 6 am.

Here is the metrics for the capacity spike:

211721-screen-shot-2022-06-13-at-52529-pm.png

And after upgrading to Premium tier
211722-screen-shot-2022-06-15-at-75724-am.png

But note how our requests/cache/data transfer has stayed fairly constant over this time period
211659-screen-shot-2022-06-13-at-52545-pm.png
211732-screen-shot-2022-06-13-at-52555-pm.png

Has anyone else experienced this? Is there any way to try and track down what's causing the huge capacity increase?

Azure API Management
Azure API Management
An Azure service that provides a hybrid, multi-cloud management platform for APIs.
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Accepted answer
  1. JananiRamesh-MSFT 27,751 Reputation points
    2022-06-17T15:29:19.877+00:00

    @Aeschleman, Luke Thanks for reaching out. This is the known ongoing issue, the engineering team is already aware of all impacted services and work is in progress to mitigate all of them.

    Summary:
    After recent service upgrade, few services may be experiencing the following symptom:

    1. Persistent High Capacity regardless of load on the service
    2. When you attempt to publish your developer portal, the publishing process never completes and the status on the Azure Portal shows “Publishing”

    Cause
    The Developer portal is designed to automatically republish itself when a new service update is released. For some services, this republish process appears to be stuck in an infinite loop and we see the portal getting republished repeatedly.

    please let me know incase of further queries, I would be glad to assist you.

    To benefit the community find the right answers, please do mark the post which was helpful by clicking on Accept Answer’ & ‘Up-Vote’.

    1 person found this answer helpful.

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  1. Pawan Tiwari 0 Reputation points
    2024-05-15T02:27:15.25+00:00

    Hi, Just wondering if this issue is still there. As we have got same issue with one of our APIM and we haven't done any changes and we got same issue. We did change it to the premium SKU and capacity did drop to 50% but again it is getting exponentially growing with incoming request being fairly constant.


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