OneDrive Site User ID Mismatch

IBN 4,476 Reputation points
2022-06-17T14:15:06.657+00:00

Hello

Please i need help on this.

The issue pertains to our user who is having problems accessing files in Teams Chats. Where other users can access and download the files fine, he will only get an error message saying "You do not have permission" message.

Even if he clicks the link to obtain permission and an email arrives saying permission has been granted, he still can't access the file.

For example in a group chat where John shared a file, Peter was unable to download it while the other users in the chat could download it just fine.

The diagnostic run on this indicated that there was an issue with his OneDrive Site User ID.

However, the files in question are in Teams Chats, not in Teams Teams (if that makes sense).

I thought files in Teams Chats were shared from OneDrive rather than SharePoint?

Maybe I'm misunderstanding the error the diagnostic identified. However, if that is an error then it does of course need rectifying as well.

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At first I thought it might be the issue where some users can’t share files properly via Teams but since other users are able to download the files just fine I don’t see how it could be that.

In the end I ran the Diagnosis on the issue and it said it had identified an issue which will prevent the suer from accessing the OneDrive site.

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This was when I ran Diag: Unable to access files shared in Teams chat

Microsoft Teams | Microsoft Teams for business | Other
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  1. JimmyYang-MSFT 58,641 Reputation points Microsoft External Staff
    2022-06-20T09:49:19.28+00:00

    Hi @IBN

    I thought files in Teams Chats were shared from OneDrive rather than SharePoint?

    Yes, you're right. Teams chat file is stored automatically in OneDrive Site. In this case,we firstly recommend you contact with the file owner to check if there are any permission settings restrict this user's access. For example. This file is only opened for the specific person or this affected user is not in the permission list. For more details about file permissions setting, you could check this part: Control the permissions of the file.

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    1 person found this answer helpful.

  2. Emily Nelson 131 Reputation points
    2022-09-29T18:46:53.353+00:00

    I had this same issue and this is the resolution for it. Keep in mind that OneDrive is based in SharePoint. When you share a file in Teams, it is added to your OneDrive account and permissions for the entire Team are added to the file and then posted to the Team. Only files uploaded to the Files tab of a channel in Teams will be stored "in Teams" which is really just being stored in a Document Library on the Team's SharePoint site.

    Cause

    The user's new account and old account were in conflict. The source of the conflict existed in the user permission records on the OneDrive accounts of those sharing with the affected user. These users had shared files with her old account, creating a user permission record on their OneDrive accounts. This record remained after the account was deleted so when the new account was created, a new user permission record was not created on the sharing user's OneDrive account and OneDrive was attempting to use that old record to authenticate.

    Resolution

    The resolution must be carried out on each individual OneDrive account affected. A Global Admin or SharePoint admin can carry these tasks out, or it can be delegated to the sharing user. If performing this task as an admin, you must first add yourself as a site collection owner on the account of the sharing user. To do this, go to the SharePoint admin center, click on More features, then Open the User profiles section. Search for the sharing user and in the results section, click on the drop-down arrow beside their Account name. Select Manage site collection owners and in the window that appears, add your own account under Site Collection Administrators. This will allow you access to their OneDrive and the ability to remove the old account from the user permissions.

    1. Navigate to the SHARING user's OneDrive All People permission list by pasting /_layouts/15/people.aspx?MembershipGroupId=0 at the end of the user's main OneDrive URL (https://mainsite-my.sharepoint.com/personal/user_email_address_com -- the format of the user's email may not match what I've written; that's the format of my company's email addresses.)
    2. Locate the affected user in the list and hover over their name and a URL will appear in the status bar area. Note the ID=#### at the end. Do not click on the user, only hover to reveal the ID.
      246222-image.png
    3. Go to the userdisp.aspx page by pasting /_layouts/userdisp.aspx?id=10&force=true onto the user's OneDrive URL and replacing the 10 with the number of the ID from the previous step. For this example screenshot the ID is 266 so you would paste /_layouts/userdisp.aspx?id=266&force=true onto the OneDrive URL.
    4. You will be taken to a People and Groups > User information page with the affected user's information listed. Confirm it is the affected user, then click Delete User from Site Collection. Confirm the deletion.
    5. Upon deletion, you will be returned to the People and Groups > All People list from step 1.
    6. All files must be re-shared with the affected user.
    1 person found this answer helpful.
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