Not able to import .csv file into Autopilot device containing multiple hash value

Ritesh Sharma 81 Reputation points
2022-06-21T11:29:05.813+00:00

Hi Team

I have created a combinedhash.csv to import multiple hashvlaue into Autopilot device using https://github.com/PowerShellCrack/PSCombineAutoPilotHashes. It is successfully created. While importing, it shows "rows formatted is correctly". However, it is not letting me import. I am clicking on import button, but nothing is happening. Please help to advise here.

213392-image.png

Windows Autopilot
Windows Autopilot
A collection of Microsoft technologies used to set up and pre-configure new devices and to reset, repurpose, and recover devices.
385 questions
0 comments No comments
{count} votes

Accepted answer
  1. Crystal-MSFT 40,541 Reputation points Microsoft Vendor
    2022-06-22T06:10:08.317+00:00

    @Ritesh Sharma , Based on my test, after running the script and import the csv, I find nothing happen when I click import button. The same result as yours.

    Then I go to do more test, manually copy the device information into one CSV using Notepad and test again. I find it is working. Then I compare the two files in Notepad and see the not working csv with Group Tag and Assigned User. But there's no value for the two attributes. Then I remove them and everything is working now.
    213630-image.png
    If your csv is also with no value of the two attributes, we suggest to remove them to see if it can work.

    Hope it can help.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

2 additional answers

Sort by: Most helpful
  1. BCMartin 1 Reputation point
    2022-08-05T11:26:25.283+00:00

    I've done just as above after having the same symptom. I still get the same inactive import button. To see what was happening, I attempted to upload an old hash list that I know worked in the past (with the headers for the last two empty columns) and they now have the same issue. These are lists sent as CSV by the manufacturer.
    However, when we run the PSCombine script on a machine, the CSV that generates does work. There seems to be no difference in the format when viewed in Notepad then saved out as ANSI.


  2. Yoav Epstein 0 Reputation points
    2024-02-21T15:37:03.8066667+00:00

    Hello, Had the same issue. What I validate is that the length of all HardwareHashs is exactly 4000 chars and the csv is encoded to UTF-8-BOM. Validate them both in Notepad++ It works now

    0 comments No comments