Edge TLS error "Site uses outdated or unsafe TLS security settings"

asked 2022-06-21T17:34:29.917+00:00
Tom Griffith 1 Reputation point

Hello. if you have a minute, I've checked the Internet Settings and TLS 1.0, TLS 1.1, TLS 1.2 are all checked and I've seemingly tried everything else on the internet regarding this error (clearing cache, etc). Anyways, in summary...

  1. was provided self-signed cert/private key in pfx file by the organization
  2. used openssl to convert pfx to pem (NOTE: when first attempting, received an error that openssl does not support RC2, so used the -legacy parameter to allow openssl to convert to pem)
  3. Converted pem to txt file and had to fix the order of certificate nodes in the txt file to server-intermediate-root.
  4. Imported the txt file into Domino keyring file, verified using their tool and it said everything cool.
  5. Pointed Domino to that keyring.kyr file, restarted server.
  6. Get "Can't connect securely to this page. This might be because the site uses outdated or unsafe TLS settings".

I tried all the internet options and client stuff. Oh, the client is running IE mode in Edge.

Secondly, there is a call to a tomcat servlet over http on the page (via javascript). Would that mess this up somehow? I did enable "display mixed elements" in the Internet Options-zone custom security settings. I wouldn't think that would do anything anyway as the setting is for embedded elements. I'm getting the error on the generic server login screen anyway. Thank you so much for any help.

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
1,326 questions
{count} votes

1 answer

Sort by: Most helpful
  1. answered 2022-06-27T16:37:00.733+00:00
    Tom Griffith 1 Reputation point

    Ok, I think I figured it out. The cipher suite used by the server side (Domino) had some outdated ones selected. I selected the remaining options they offered and that created an agreed upon protocol with the browsers. Thank you so much for your help.

    No comments