Do I need to do anything special to RDP to Azure VM?

FJcmdk4488 56 Reputation points
2022-06-21T17:56:44.58+00:00

Created a new VM but I am not sure how to RDP into it? I tried but get an error that says it can't connect.

"Remote Desktop can't connect to the remote computer for one of these reasons:

  1. Remote access to the server is not enabled
  2. The remote computer is turned off
  3. The remote computer is not available on the network"

I verified that RDP is enabled on the VM, it is turned on, and it can get out to the internet. I've tried my work and home networks with the same error. Is there anything special needed to get RDP to work on an Azure VM?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
4,598 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Francisco Beltran 1 Reputation point
    2022-06-21T18:06:29.813+00:00

    When you create the VM usually a Network Security Group is also created, check that the port for te RDP is open in the NSG


  2. FJcmdk4488 56 Reputation points
    2022-06-22T15:45:00.85+00:00

    This is what fixed the problem for me. - https://learn.microsoft.com/en-us/troubleshoot/azure/virtual-machines/troubleshoot-rdp-nsg-problem#symptom

    Symptom
    You cannot make an RDP connection to a VM in Azure because the RDP port is not opened in the network security group.

    Solution
    When you create a new VM, all traffic from the Internet is blocked by default.

    To enable the RDP port in an NSG, follow these steps:

    Sign in to the Azure portal.

    In Virtual Machines, select the VM that has the problem.

    In Settings, select Networking.

    In Inbound port rules, check whether the port for RDP is set correctly. The following is an example of the configuration:

    Priority: 300
    Name: Port_3389
    Port(Destination): 3389
    Protocol: TCP
    Source: Any
    Destinations: Any
    Action: Allow

    If you specify the source IP address, this setting allows traffic only from a specific IP address or range of IP addresses to connect to the VM. Make sure that the computer you are using to start the RDP session is within the range.

    No comments