Network Shares mapped to DFS namespace. On boot PC cant see the path

Brad Blank 1 Reputation point
2022-06-22T13:20:04.447+00:00

OK i have been scouring the internet to find the issue but i cant seem to figure this out. About 2 weeks or so we started to have an issue where on boot user drives wont map correctly.

We have the user drives mapped to a folder in the \domain\Public namespace but for some reason windows doesnt see the location untill you enter the path in file explorer.

For example. I have a U drive mapped to \domain\Public\Usershare\Name. When i reboot my machine and log back in i can run a cmd to try to map a network drive manually and it fails saying that the path doesnt exist. if i go directly to the path its trying to map it works just fine and after going to the location i can run the cmd and it works just fine.

We have about 450 users that have this issue all the sudden and its a nightmare.

We have tried using GPO for drves, Ad profile mappigs and even tried to add the networklocation for the namespace but nothing works unless they enter the path in file explorer, hit enter and then run the script manually.

Any one ever seen this

We are a windows shop using DFS namespace 2008 model on server 2016 and 2019 mix.

Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
1,935 questions
Windows Server Infrastructure
Windows Server Infrastructure
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Infrastructure: A Microsoft solution area focused on providing organizations with a cloud solution that supports their real-world needs and meets evolving regulatory requirements.
427 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 37,301 Reputation points
    2022-06-23T07:43:08.16+00:00

    Hi there,

    This error typically occurs because the DFSN client cannot complete the connection to a DFSN path.The connection may fail because of any of the following reasons:

    -Failure to connect to a domain controller to obtain a DFSN namespace referral
    -Failure to connect to a DFSN server
    -Failure of the DFSN server to provide a folder referral

    Issue with DFS-N and mapped drive letters https:// learn.microsoft.com/en-us/answers/questions/202381/issue-with-dfs-n-and-mapped-drive-letters.html

    Here is a link that has some additional troubleshooting steps which you can try and see if helps in overcoming your issue. Troubleshoot Distributed File System Namespace access failures in Windows https:// learn.microsoft.com/en-us/troubleshoot/windows-server/networking/dfsn-access-failures

    ----------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept it as an answer–