Accessing Azure Synapse dedicated sql pool using jdbc

Navin Ladda 21 Reputation points
2022-06-23T16:10:49.44+00:00

I have been trying to connect to Azure Synapse Analytics Dedicated SQL pool over JDBC.
I am using DBeaver as the query tool here.
Microsoft SSMS ver 18 works fine, but wanted to have a single tool to connect to various database platforms we have, hence wanted to use it with Dbeaver.

I have read several articles to setup Dbeaver to reach this stage.
I downloaded MS JDBC Driver for SQL version 10.2.
Set up a connection in Dbeaver using this driver. Added driver files for MSAL4J as I am using Active Directory with Password authentication.

https://learn.microsoft.com/en-us/azure/synapse-analytics/sql/connect-overview

I got the JDBC URL from within Azure Portal which looks like this (site specific details removed here, but had correct values for our Azure subscription)

jdbc:sqlserver://xxx.sql.azuresynapse.net:1433;database=xxx;user={your_username_here};password={your_password_here};encrypt=true;trustServerCertificate=false;hostNameInCertificate=*.sql.azuresynapse.net;loginTimeout=30;authentication=ActiveDirectoryPassword

I have even gone Synpase Workdspace, Networking and added a firewall rule for my client ip address.
As serverless sql pool was not doing anything when I clicked on it, created a small Dedicated SQL pool and testing connection with that.

Yet anytime I try the test option within Dbeaver to see if the connection is working, I get thrown this error :

Request was throttled according to instructions from STS. Retry in 95312 ms.

I have tried Googling what that means and nothing relevant shows up.

Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
4,132 questions
{count} votes

Accepted answer
  1. MartinJaffer-MSFT 25,991 Reputation points
    2022-06-28T15:37:33.613+00:00

    I am trying out the other authentication Methods. Active Directory -MFA worked very well. It opened up a browser window for a moment, though.

    215779-image.png

    Tryign again the Active Directory with password:
    I intentionally gave the wrong password a few times, then after that I got your Request was throttled according to instructions from STS. Retry in 14954 ms. message. Trying again and again, I notice the number decreased, and didn't matter what password I gave.
    Eventually I got the AADSTS50076: Due to a configuration change made by your administrator, or because you moved to a new location, you must use multi-factor authentication to access ' message again.

    From this behavior, I believe it is a case of "You got the password wrong too many times in a row. We will stop letting you try to login, because this looks like brute-force password hack. You can try again later."
    My Smartphone does something similar.

    Does this make sense @Navin Ladda ?

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful