Language (Region) Issue Autopilot/Pre-Provisioning

Chetan Sharma 61 Reputation points

Hi All,

I am deploying an autopilot profile that it is configured to choose Language (region) as 'OS Default'. Although i choose another language (German) during OOBE setup (different from default (English)) , it does not change when i finish autopilot process and enter to the desktop.


Any help will be appreciate.

Thank you

Windows Autopilot
Windows Autopilot
A collection of Microsoft technologies used to set up and pre-configure new devices and to reset, repurpose, and recover devices.
385 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Pavel yannara Mirochnitchenko 11,411 Reputation points

    We have similar problems with Finnish language, time format is wrong and localization is still set to somewhere else. I solved this problem with Powershell script to set correct time zone and other locale settings. I believe it is more of Windows problem, not Autopilot, because same result will be if I install computer for home user. I thought this problem was only around Finnish.

    1 person found this answer helpful.

  2. Chetan Sharma 61 Reputation points

    My bad ... I should have been more specific that we are using White Glove provisioning method and I see Microsoft has addressed this issue in their documentation.

    In Windows 10, version 2004 and later, if the Autopilot deployment profile Language/Region setting is not set to User Select, then OOBE will progress past the language/region/keyboard selection screens. This causes the pre-provisioning technician to arrive at the Azure AD login page, which is too late to enter pre-provisioning. This issue is fixed in Windows 11.

    Anyways .. thank you for your time and suggestions. Appreciate !

    1 person found this answer helpful.