How to prevent edge browser from automatically jumping from IE mode to edge mode?

宏伟 孙 1 Reputation point
2022-07-04T06:46:09.617+00:00

When using the IE compatibility mode of edge to access the website, it will automatically switch to the edge mode. I found that it is a code window affected by hash. Once this value is set, it will switch from IE mode to edge mode. But my website can only be accessed in IE mode. Is there any way?

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,031 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Deepak-MSFT 2,191 Reputation points Microsoft Vendor
    2022-07-04T07:34:05.53+00:00

    Hi @宏伟 孙 ,

    I would like to confirm with you, that are you facing this issue at the time of login(authentication)? Are you trying to redirect to a URL that is not added in the sitelist.XML file?

    If you are facing this issue at the time of login then you will need to check the Fiddler trace and try to find the URLs that are responsible for the authentication. You need to configure these URLs as neutral sites in the sitelist.xml file.

    Else, you could try to configure the group policy Specify how "in-page" navigations to unconfigured sites behave when started from Internet Explorer mode pages.

    Best Regards,
    Deepak

    ----------

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.