Automationaccount :parentResourceNotFound

Prachi 1 Reputation point
2022-07-04T18:12:56.82+00:00

I have an automation account A1 in a resource group say rg1 in subscription S1
I have another automation account A2 in rg2 in same subscription S1
I want to link Automation account A1 to log analytics workspace of A2.
But received parentresource not found error
How to solve it?

Azure Automation
Azure Automation
An Azure service that is used to automate, configure, and install updates across hybrid environments.
1,075 questions
{count} votes

1 answer

Sort by: Most helpful
  1. AnuragSingh-MSFT 18,666 Reputation points
    2022-07-05T10:48:48.133+00:00

    Hi @Prachi ,

    Thank you for reaching out to Microsoft Q&A for this question.

    Based on my understanding, you are trying to link 1 Log Analytics Workspace to 2 different Azure Automation Account. This cannot be done.
    An Azure Automation Account can only be linked to a Log Analytics Workspace, which is not linked to any other Automation Account.

    Also, only certain regions are supported to link Automation Account and Log Analytics Workspace together. Please refer to this link for more details -
    Supported regions for linked Log Analytics workspace

    Please let me know if you have any questions. If your question was related to something else, can you please clarify it with additional context/example, to help me understand it better.

    ---
    Please 'Accept as answer' and ‘Upvote’ if it helped so that it can help others in the community looking for help on similar topics.

    0 comments No comments