Windows store apps error in VDI "this app does not support contract specified or not installed"

Raghunayakula Dilip Kumar 0 Reputation points
2022-07-04T19:02:40.78+00:00

Hi Folks, this is regarding storeapp issues in VDIs
We are running a Citrix vdi environment and recently upgraded master images from 1909 to 21H2. Post upgrade users started complaint that calculator and screen sketch apps are not launching , we have gone through the event logs and found the below error
“Activation for Microsoft.ScreenSketch_8wekyb3d8bbwe!App failed. Error code: This app
does not support the contract specified or is not installed., Activation phase: Deployment"
We have tried uninstall appaxpackage and reinstall , we have tried reregister appc packages but nothing worked
Few articles are telling to run sfc scan now , rollback and do a fresh image but as there are lot of changes done in 1909 we can’t do that.
No help or articles found with same error. Please help us to resolve this issue without asking to rollback and do a fresh installation of 21H2

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,172 questions
{count} votes