SCCM 2203 Update stuck downloading

Franz Schenk 1 Reputation point
2022-07-05T09:52:39.727+00:00

Should Upgrade an SCCM 2103 Siteserver, but several Updates are hanging in the "downloading state" for months.

217617-sccm-downloading.png

What I have done so far:

  1. Examined dmpdownloader.log and found that only two files can not be downloaded: ERROR: Failed to download redist for 89735386-930a-490a-909b-65101ba8c02c with command /RedistUrl https://go.microsoft.com/fwlink/?LinkID=2189441 /LnManifestUrl https://go.microsoft.com/fwlink/?LinkId=2189438 /RedistVersion 202203 /NoUI "\SBA-SCM-01.DOMAIN.COM\EasySetupPayload\89735386-930a-490a-909b-65101ba8c02c\redist" .
    But manually downloading these two files from a browser does work fine. Have saved these two files in the folder EasySetupPayload\89735386-930a-490a-909b-65101ba8c02c\redist. But when checking for updates in the SCCM Console, setupdl.exe tries to download these files again and fails, and the download never finish.
  2. Tried to download these two files with the following command: C:\Program Files\Microsoft Configuration Manager\cd.latest\SMSSETUP\BIN\X64\setupdl.exe" /RedistUrl https://go.microsoft.com/fwlink/?LinkID=2189441 /LnManifestUrl https://go.microsoft.com/fwlink/?LinkId=2189438 /RedistVersion 202203 "c:\temp\redist".
    This results in an error message that dthe download cannot continue and that configmgrsetup.log should be examined. This logfiles contains several lines with the error "ERROR: Download() failed with 0x80072F8F". Research for this error code says that either the date/time is incorrect, which is not the case, or that there is a problem with windows activation.
  3. Tried to reset and clean the downloads with CMUpdateReset.exe. But I can not make this tool to work. When running on the Site Server which also hosts the SQL database, I'm getting the error "0x80131904 - A connection was successfully established with the server, but then
    an error occurred during the login process. (provider: SSL Provider, error: 0 - The target principal name is incorrect.). When running CMUpdateReset.exe from a remote server, I'm getting the error "0x80131904 - A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.).
  4. Researched a lot. Have found the thread https://learn.microsoft.com/en-us/answers/questions/897816/sccm-download-error.html which describes exactly the same problem. But the solution was to upgrade the Server OS from Server 2012 to 2019. Our customers SCCM Server also runs on server 2012, but upgrading is not an option due to licensing reasons.

Any advice? Thank you all in advance for any help.
Franz

Microsoft Configuration Manager Updates
Microsoft Configuration Manager Updates
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Updates: Broadly released fixes addressing specific issue(s) or related bug(s). Updates may also include new or modified features (i.e. changing default behavior).
925 questions
Microsoft Configuration Manager
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Garth 5,791 Reputation points
    2022-07-05T12:09:20.48+00:00

    When you say download the file manually, are you downloading them using the local system account or your account?
    This blog give the basic steps to test the download as the local system account. https://www.recastsoftware.com/resources/how-to-download-a-software-update-outside-of-the-sccm-console/

    1 person found this answer helpful.
    0 comments No comments

  2. Franz Schenk 1 Reputation point
    2022-07-05T12:41:08.103+00:00

    Thank you, it was worth a try, but didn't help. Can also successfully manually download the updates from a browser under the system account (psexec -i -s ...). So, downloading the updates manually works with the system and a user account, but the SCCM setupdl.exe tool does not work at all.

    0 comments No comments

  3. Vincent Devos PRO 1 Reputation point
    2022-07-06T13:49:59.463+00:00

    Hi,
    so, same issue. Server 2012R2 with SCCM 2103. previous SCCM versions 2107 and 2111 stuck at downloading, but ok I was planning to skip and go for the latest 2203.
    Run the CMUpdateReset.exe and cleanup packages. Then restart SMS_EXECUTIVE and retry.
    218147-image.png

    Got stuck at downloading. Did some research and try the SETUPDL.EXE from SCCM\EasySetupPayload\89735386-930a-490a-909b-65101ba8c02c\SMSSETUP\BIN\X64 to download files into separate folder E:\TEMP\SCCM2203-redist. Check the generated log file redist.log:
    218222-image.png
    see clearly the file causing issue: NDP462-KB3151800-x86-x64-AllOS-ENU.exe

    Try the URL https://go.microsoft.com/fwlink/?LinkID=2171070 in IE directly on that SCCM server:
    218232-image.png

    Got error accessing that file, seeing it's redirect to https://download.visualstudio.microsoft.com

    So I'm currently investigating if that site is blocked by FW rules... but

    My question is:
    if I would be able to download all the needed files separately on another machine, then, can I just copy them in the SCCM\EasySetupPayload\89735386-930a-490a-909b-65101ba8c02c\redist folder and move on? is this working?

    0 comments No comments

  4. Franz Schenk 1 Reputation point
    2022-07-07T13:30:51.997+00:00

    Could solve the problem, but not the problem cause: The download doesn't work anymore on Server 2012, despite Microsoft promise that the EOL for this OS is October 2023. Obviousely, Microsoft didn't test their SW on server 2012 anymore, which caused us (and most probably to many others) hours of additional work.

    When running the command C:\Program Files\Microsoft Configuration Manager\cd.latest\SMSSETUP\BIN\X64\setupdl.exe" /RedistUrl https://go.microsoft.com/fwlink/?LinkID=2189441 /LnManifestUrl https://go.microsoft.com/fwlink/?LinkId=2189438 /RedistVersion 202203 "c:\temp\redist". on the site server, the command abandons with an error message that language files can not be downloded.

    When running exactely the same command on a server 2016, 48 files are downloaded to c:\temp\redist. After the download, I copied these files to the directory that was logged in dmpdownloader.log , in our case EasySetupPayload\89735386-930a-490a-909b-65101ba8c02c\redist, and then after restarting the SMS_DMP_DOWNLOADER Service, the status from the 2203 Build changed from downloading to "ready to install" after a few minutes.

    0 comments No comments