Microsoft Teams : Windows Defender firewall blocked some of the app features

Boopathi Subramaniam 2,416 Reputation points


Users are receiving the below message this week.

Below Windows Inbound firewall already in place.
Please help the reason and solution for the message

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
5,306 questions
No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Ralf Lauerwald 26 Reputation points

    I actually think I've found the solution.

    create a firewall rule that blocks everything, but deactivate it:
    New-NetFirewallRule -DisplayName "Teams.exe" -Program "%LocalAppData%\Microsoft\Teams\current\Teams.exe" -Profile Domain,Private,Public -Description "Teams.exe" -Group "Teams" -Direction Inbound -Protocol TCP -Action Block -Enabled false -EdgeTraversalPolicy Block
    New-NetFirewallRule -DisplayName "Teams.exe" -Program "%LocalAppData%\Microsoft\Teams\current\Teams.exe" -Profile Domain,Private,Public -Description "Teams.exe" -Group "Teams" -Direction Inbound -Protocol UDP -Action Block -Enabled false -EdgeTraversalPolicy Block

    ps: unbelievable what an administrator has to come up with because Microsoft is too stupid to offer a clean software solution :(

    No comments

  2. Ralf Lauerwald 26 Reputation points

    our users do not have administrator rights and cannot grant this firewall approval.

    the unbelievable is that this pop up also appears although the necessary firewall rules have already been set by us administrators.

    new-NetFirewallRule -DisplayName "Teams.exe" -Program "%LocalAppData%\Microsoft\Teams\current\Teams.exe" -Profile Domain,Private,Public -Description "Teams.exe" -Group "Teams" -Direction Inbound -Protocol TCP -Action Allow -EdgeTraversalPolicy DeferToUser
    new-NetFirewallRule -DisplayName "Teams.exe" -Program "%LocalAppData%\Microsoft\Teams\current\Teams.exe" -Profile Domain,Private,Public -Description "Teams.exe" -Group "Teams" -Direction Inbound -Protocol UDP -Action Allow -EdgeTraversalPolicy DeferToUser

    the firewall pop up from Teams apparently always appears, regardless of whether there are firewall problems or not.
    now all users have to constantly click away these messages and cannot use teams 100%.
    @microsoft: what a shit!

    No comments

  3. Bob 6 Reputation points


    Its Fine that the firewall is doing its Job and protecting us from the Evils of the world, but could the message about what was blocked be any more Generic ( read Useless )

    Specifically what Sites / address / call was made ?
    Telling me something is inbound from the Internet is not helpful ?

    No comments

  4. Sharon Zhao-MSFT 24,656 Reputation points Microsoft Employee

    @Boopathi Subramaniam ,

    It recommends you choose Allow access in the popup.

    This message appears when an application wants to act as a server and accept incoming connections. The Windows Firewall blocks incoming connections by default.

    But the first time it blocks connections to a new application, this message pop up. You can then choose whether to allow the connection through. This ensures connections aren’t silently blocked without your knowledge.

    For more details, please refer to this article:

    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.