Unable create any new resource due to System deny assignment created by Azure Databricks

Arundhati Sen 151 Reputation points
2022-07-08T07:23:22.43+00:00

I am unable to create any new resource or delete the resource group created my Databricks. It has a System deny assignment created by Azure Databrick which is blocking all actions ![218830-image.png][1] [1]: /api/attachments/218830-image.png?platform=QnA I saw few other posts regarding this issue, and it is recommended there to create a MS support ticket to remove the Deny Assignment. But my Subscription is Basic Plan and I am unable to raise support ticket. Please help me with a solution or help me raise a free support ticket for this issue

Azure Databricks
Azure Databricks
An Apache Spark-based analytics platform optimized for Azure.
1,848 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. SaiKishor-MSFT 17,141 Reputation points
    2022-07-08T18:36:21.213+00:00

    anonymous user Thank you for reaching out to Microsoft Q&A. I understand that you are having issues with deleting your Azure Databricks created Resource Group or create a new one.

    Please follow steps provided in this post here i.e.,

    when we create a Azure Databricks workspace, by design it will automatically create Databricks Managed resource Group. The managed resource group must exist as this is where your cluster(s) will be created. To ensure that nothing breaks them, they are placed in a separate resource group (managed resource group) that has a super lock on it so you cannot modify anything in it.

    Coming back to deletion part, in order to delete this managed resource group, First you need to delete Azure Databricks workspace that is associated with it. Then as part of the process even the Azure Databricks Managed resource Group gets deleted.

    Inorder to find the Databricks workspace associated with that Managed resource group, please follow below steps.

    1. Open managed resource group that you want to get rid of, then go to "Deployments" under "settings" and you should see the Databricks workspace name as below.
      219061-1565275.jpg
    2. Then open that particular Databricks workspace and click on "Delete" button, this will eventually delete your managed resource group. After you receive a notification that Delete deployment is complete, refresh your portal and see if those two resources get deleted. I have tried this and worked for me.
      219062-1565281.jpg
      1. I would also recommend to clear your browser cache, restart browser and then open portal to check if those resources got deleted.

    Hope this helps. Please let us know if you have any further questions and we will be glad to assist you further. Thank you!

    Remember:

    Please accept an answer if correct. Original posters help the community find answers faster by identifying the correct answer. Here is how.

    Want a reminder to come back and check responses? Here is how to subscribe to a notification.

    0 comments No comments

  2. Arundhati Sen 151 Reputation points
    2022-07-16T10:07:14.803+00:00

    I deleted the previous Databricks using the steps mentioned in the above answer. But when new Databricks resource is created, again Databricks Managed resource Group created has the System Denied Assignment. Again unable to create any new resource. What is the solution here? how can this System Denied Assignment be removed or not be there while creating ADB. Please help, I am unable to perform any action because of this deny assignment 221381-image.png][1] [1]: /api/attachments/221381-image.png?platform=QnA [@ @Azure databricks