Need Outlook Maximum File Size and Maximum Months Cached Increased

Michael Adams 306 Reputation points
2022-07-10T02:21:26.943+00:00

I have a user with 99 GB in their Outlook 365 account. I need to archive emails older than five years old to a PST file. I can't do it. Even when I set the cache level in the Outlook desktop app to "All", I only get a year's worth of emails.

If you try to run Outlook without "Cached Mode" on, I get all of the emails showing. However, if I click on "Clean Up Old Items", it gives an error message "The attempted operation failed. An object could not be found."

I did find a document that says to change some registry entries to allow Outlook to cache more emails.

https://practical365.com/outlook-cached-mode-ost-file-sizes/

However, the maximum file size in this document is 50 GB. The user has an account of 99 GB. The maximum number of months can be increased to 60 months. I need 120 months.

Any ideas to get past these limits would be appreciated.

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,732 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. T. Kujala 8,686 Reputation points
    2022-07-10T06:17:01.967+00:00

    Hi @Michael Adams ,

    Have you tried to create a new Outlook profile and then set cache level to all?

    Does it then get all emails?

    0 comments No comments

  2. Faery Fu-MSFT 15,516 Reputation points Microsoft Vendor
    2022-07-11T03:03:04.467+00:00

    Hi @Michael Adams ,

    As far as I know, in Outlook 2010, 2013, 2016, 2019 and Microsoft 365, the default limit of data file size is set to 50GB.

    Based on my search, you can increase the limit via the registry to manage the Outlook data files size.

    To modify the registry, here is an document for reference: https://www.msoutlook.info/question/large-exchange-mailboxes-and-the-ost-file-size-limit
    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    For example, if you want to set the maximum size to100GB and warning at 95GB, you can refer to the following steps:
    Important: Follow the following steps carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.
    Step1: Click Start, click Run, type regedit, and then click OK.
    Step2: In the left pane, expand the following registry key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\Outlook
    (Note You may have to create the registry values if they do not exist. If the registry values do not exist, follow these steps to create them.)
    Step3: Right click Outlook, point to New, and then click Key.
    219348-key.png
    Step4: Type PST, and then press ENTER.
    219339-pst.png
    Step5: Create the following 2 new DWORD values, in the Edit DWORD Value window, choose Decimal and type the value in the Value data box, and then click OK.
    219362-dword.png
    219318-edit.png
    219372-m.png
    Hope above can help you!


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  3. Michael Adams 306 Reputation points
    2022-07-19T23:01:16.677+00:00

    @T. Kujala

    Apparently, "All" isn't really all anymore.

    0 comments No comments

  4. Michael Adams 306 Reputation points
    2022-07-19T23:02:14.967+00:00

    @Faery Fu-MSFT

    I'll give the registry entry trick a try. Thanks!


  5. Michael Adams 306 Reputation points
    2022-08-04T16:27:18.73+00:00

    Anyone got any additional ideas? I'm at a dead end. Apparently, Microsoft Outlook 365 has changed enough that the suggestions given so far do not work.

    0 comments No comments