AADSTS900561 error logging into Azure DevOps From Edge Browser

Nancy Folsom 21 Reputation points
2022-07-11T21:25:06.95+00:00

I am trying to use Edge to log in to Azure DevOps. This has worked in the past, but now when I try to log in I get:

AADSTS900561: The endpoint only accepts POST requests. Received a GET request.

I've read the links that come up for this message, but the recommendations are for Chrome, and I can't seem to find the settings in Edge that correspond. I'm not blocking cookies. But to be sure I've added https://login.microsoftonline.com/ to allowed site.

I can log in on other browsers. I have logged in to DevOps in Edge in the past.

Edge version 103.0.1264.49, 64-bit

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,041 questions
0 comments No comments
{count} votes

Accepted answer
  1. Yu Zhou-MSFT 11,471 Reputation points Microsoft Vendor
    2022-07-13T06:15:54.457+00:00

    Does it work if you add a new profile in Edge and sign in using that profile? Pay attention when you sign in there might be a prompt which asks you if you want to switch profiles. Please don't switch profile and make sure you're using the new empty profile to login.


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Regards,
    Yu Zhou

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Yu Zhou-MSFT 11,471 Reputation points Microsoft Vendor
    2022-07-12T03:45:19.163+00:00

    Hi @Nancy Folsom

    Please navigate to edge://settings/content/cookies in Edge and make sure Block third-party cookies is turned off. Please refer to the settings below:

    219713-image.png

    Besides, you can try to login in InPrivate window in Edge. If it can login in InPrivate mode, the issue might be related with cookie and cache. You can try to clear browser cookies and cache in edge://settings/clearBrowserData then test again.


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Regards,
    Yu Zhou