Reference Synapse Notebook fails in Pipeline

eugenia apostolopoulou 76 Reputation points
2022-07-12T14:34:58.76+00:00

Hello,

I have a pipeline which includes a synapse notebook, let's say Notebook1 and in Notebook1 I'm trying to reference another synapse notebook, Notebook2. I have tried do it using both %run and mssparkutils.notebook.run() but either way I have an error saying that the referenced notebook cannot be read possibly because it doesn't exist.
Actions that I have done so far:

  1. Check the box 'Enable unpublished notebook reference'
  2. Publish notebooks
  3. Run the pipeline not only from a feature branch but also from main branch
    Nothing has worked. Noted that when I run the notebook itself, it runs successfully. The issue is that I cannot execute it via pipeline.
    Please for your input!
    Thank you in advance!
Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
4,119 questions
0 comments No comments
{count} votes

Accepted answer
  1. ShaikMaheer-MSFT 37,216 Reputation points Microsoft Employee
    2022-07-13T13:12:07.747+00:00

    Hi @eugenia apostolopoulou ,

    Thank you for posting query in Microsoft Q&A Platform.

    I tried similar implementation; I am not getting error. I suspect that may be referenced notebook not published or referenced notebook name or path are incorrectly mentioned. Kindly recheck.

    Please check below my implementation which I tried and worked fine.
    220451-image.png

    Kindly refer below videos to understand about %run and run() function.
    %run command to reference another notebook with in current notebook in Azure Synapse Analytics
    run() function of notebook module in MSSparkUtils package in Azure Synapse

    Please share screenshots of your implementation also if unable to figure out issue.

    Hope this helps.

    ------------------

    Please consider hitting Accept Answer button. Accepted answers help community as well.


0 additional answers

Sort by: Most helpful