Unable to Deploy Latitude 5520s Using Windows Deployment Service (WDS)

Darian Ho 1 Reputation point
2022-07-13T20:32:28.293+00:00

Hello,

We have set up Windows Deployment Service (WDS) in our environment to streamline our deployment process. So far, we have used it to deploy Dell OptiPlex 3090 Micro machines without an issue, but it doesn't seem to work with the Dell Latitude 5520s.

The error message that I am getting is "WdsClient: An error occurred while obtaining an IP address from the DHCP server. Please check to ensure that there is an operational DHCP server on this network segment." The DHCP server is fully functional as determined by the successful deployment of those OptiPlex machines. The Latitude is able to contact the WDS server and bring up the Windows Boot Manager screen, where it shows it has a Client IP address, but once it boots into Windows PE it loses connection and brings up that error.

I have tried adding network drivers from Dell's WinPE 10 driver pack and Intel's I219-LM driver pack to the Windows 10 (x64) boot image without any luck. I also upgraded the BIOS to the latest version, which is 1.19.1 right now. Last thing I've tried is switching the storage operation to AHCI/NVMe from RAID which didn't work either.

If anyone has a different solution, please let me know.

Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,510 questions
Windows 10 Setup
Windows 10 Setup
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,877 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. S.Sengupta 14,436 Reputation points MVP
    2022-07-18T01:19:03.377+00:00

    This issue occurs if the WDS boot image does not contain a network driver.

    Kindly go through the following link:

    https://www.urtech.ca/2018/10/solved-wdsclient-an-error-occured-while-obtaining-ip-address/