Unable to set a User for Send As for a Distribution Group - hybrid env.

Ben Rollman 6 Reputation points
2022-07-14T14:11:48.447+00:00

Exchange Server 2016 in hybrd with O365. Trying to set up an owner of a distribution group to be able to Send As (which I thought they'd have as an owner but they're getting the "You don't have permission to send on behalf of the specified user). Go into the group, UI open up to the settings > group delegation, + to add user. The only users in the list are the other distribution groups. I don't see a list of users.

I have not tried any PS commands yet. We've been in this set up for years and I can't imagine they haven't tried this before, so I'm concerned something changed.

-edit-

I just found this article, wondering if this could be helpful.

https://techcommunity.microsoft.com/t5/office-365/struggling-with-hybrid-send-as-permissions-for-distribution/m-p/1086044

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,227 questions
Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,802 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Andy David - MVP 138.6K Reputation points MVP
    2022-07-14T16:22:57.813+00:00

  2. KyleXu-MSFT 26,201 Reputation points
    2022-07-20T06:56:30.603+00:00

    @Ben Rollman

    From this article, we can know that Send as not supported in hybrid environments. You could manually add the Send As permissions in both environments.

    If you want a mailbox could send as group, you need to use Group as the Identity" (You need sync group to Exchange online first):
    From Exchange on-premises:
    222611-1.png

    From Exchange online:
    222559-2.png

    After adding permission, you need wait a while for it to take effect.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



  3. Butnikošarovski Jakub 0 Reputation points
    2023-10-04T11:41:29.2933333+00:00

    Tried everything from here and others, for me helped to changed owner and change it back to me. It started to work when I changed owner from me to other user. So I tried if it's problem of same owner and user or something. But wasn't able to replicate the problem with other DL. So I changed the owner back to me and it stayed working.

    0 comments No comments