Windows Defender Dashboard "broken" after upgrade to Windows 11: (You'll need a new app to open this windowsdefender link. Look for an app in the Microsoft Store))

thatkeeran 1 Reputation point
2022-07-14T19:52:03.187+00:00

Hey everyone. Need a bit of help here.

I recently upgraded our business computers from Windows 10 to Windows 11. Everything is fine, but the specific username where the update took place is not able to open Windows Security Dashboard anymore, neither from the taskbar tray or from Settings. I get a message asking me to select an app from the Microsoft Store.

The computers are in a domain and they do not use local usernames (I think they are called roaming profiles?).

So far I have tried:

1) Using the PowerShell as administrator and then: Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage.

2) Reinstalling Windows 11 by downloading a fresh ISO, then selecting keep files and apps.

3) Since it works for other users that were not used, my assumption is that it is profile-specific. I tried deleting the user via Regedit and then deleting the user folder.

This launched the typical user preparation screen you get when you start windows for the first time ("We are getting things ready for you"), but that user still cannot run the dashboard even after doing all this.

The Windows Defender Dashboard issue affects only the user (domain user profile) that was used to upgrade from Win10 to Win11. (ie. if "user a" was the one active when using upgrade via Windows update, that user will not be able to open the dashboard.

Other notes:

1) Creating a new local user is not an option, neither creating another user in the domain, as these must mirror the email addresses of the company (ie misterx user on the domain has an email misterx (at) company (dot) com and so on)

I'm not an expert nor an experienced system administrator (I just really like IT) and have never managed a domain, but I do grasp some concepts. I ask that you please be patient as I may need to ask for clarification. We just have 5 computers connected to a server. Microsoft telephone support for retail did not want to help me as this is a business; Microsoft business telephone did help me but only suggested reinstalling (refreshing but keeping apps and files), Microsoft forums redirected me to this forum. Your help will be greatly appreciated.

See below the error of Windefender and the "about" section of one of the computers.

Thank you

220827-windows-dashboard-error.jpg220883-computer-info.jpg

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
7,641 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. S.Sengupta 14,441 Reputation points MVP
    2022-07-15T00:48:58.913+00:00

    From your description it seems to be a profile related issue.

    You have already tried with PowerShell command and reinstalling Windows.

    One thing left go for a clean install.

    0 comments No comments

  2. thatkeeran 1 Reputation point
    2022-07-15T10:31:31.983+00:00

    Unfortunately this is not possible. Is there any way to report this bug to microsoft?

    0 comments No comments

  3. Limitless Technology 39,196 Reputation points
    2022-07-15T10:47:11.997+00:00

    Hi there,

    Is this behavior same for all the five users when logging through the domain profile ? As I can see that you have stated that only the active profiles are facing this .

    Can other profiles which we inactive during the upgrade able to open the dashboard ?

    I would suggest download process monitor - Log in through the profile see the Backend while you are opening the dashboard. Repeat the same for the profile where it works . This might shed some light about where to start the troubleshoot . I also guess this might be a bug and reporting to Microsoft using the feedback hub is also a great option.

    Process Monitor is an advanced monitoring tool for Windows that shows real-time file system, Registry and process/thread activity. https://learn.microsoft.com/en-us/sysinternals/downloads/procmon

    I hope this information helps. If you have any questions please let me know and I will be glad to help you out.

    ------------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept it as an answer--