Microsoft remote desktop v10.7.7(2001) unable to dispaly in multiple monitors

MZ 1 Reputation point
2022-07-15T00:56:29.72+00:00

I'm using Mac book pro OS Monterey v12.4, with Apple M1chip. When I try to connect to my remote desktop with using all monitors selected, it won't project to the monitor. It will display on my Mac screen only, with a weird size ratio (enlarged window and font size).

I found that this issue only exists when I arrange my external monitor to be above my Mac screen. When I rearranged to be side by side, it will work fine. I remember this happened early this year (January?) in one of the versions released, and got fixed later, so might be worth to revisit that release.

In addition, I was told to download the beta version and I found that it won't accept my account and password as a valid login. I had no problem using beta software earlier this year, and I am not sure what went wrong this time. (I did recently change my account password; not sure if that affects some cache it created when I used the beta software last time). I tried a few versions, and none worked. I also made sure all the configurations are exactly the same as the one I have in the official software. I rely on these beta/historical versions a lot when the official software fails to work. So it will be helpful if you can help me check this too. Thank you!

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,146 questions
{count} votes