Issue w Log Shipping between different domains.

chrisrdba 276 Reputation points
2020-09-11T20:01:52.8+00:00

Greetings. I'm using this link to try and get LS set up between servers in different domains.

https://www.mssqltips.com/sqlservertip/2562/sql-server-log-shipping-to-a-different-domain-or-workgroup/

As noted in the instructions, I have:

  1. Created an account in each domain that has the same username and password for the SQL Server Agent Account.
  2. Created a folder/ share in both the source and destination, and granted the SQL Server Agent account permissions.
  3. Specified the correct folder on the source and destination.

However, I keep getting the following error. Note that I've tried using the actual folder instead of the share name, and also tried not using the FQDN. Nothing changes except the verbiage in the error (same issue though).

Any ideas?

Microsoft (R) SQL Server Log Shipping Agent
[Assembly Version = 13.0.0.0, File Version = 13.0.5026.0 ((SQL16_PCU_Main).180318-0835)]
Copyright (c) 2016 Microsoft. All rights reserved.

2020-09-11 15:45:00.54 ----- START OF TRANSACTION LOG COPY -----
2020-09-11 15:45:00.62 Starting transaction log copy. Secondary ID: '6dfd8002-3e61-4daf-b8e9-ad9fb381dd83'
2020-09-11 15:45:00.62 Retrieving copy settings. Secondary ID: '6dfd8002-3e61-4daf-b8e9-ad9fb381dd83'
2020-09-11 15:45:00.63 Retrieved copy settings. Primary Server: 'sourceServer', Primary Database: 'dbaLS', Backup Source Directory: '\sourceServer.mydomain', Backup Destination Directory: '\destServer.otherDomain\dbaLS', Last Copied File: '<None>'
2020-09-11 15:45:00.65 Copying log backup files. Primary Server: 'sourceServer', Primary Database: 'dbaLS', Backup Source Directory: '\sourceServer.mydomain', Backup Destination Directory: '\destServer.otherDomain\dbaLS'
2020-09-11 15:45:01.30 * Error: The user name or password is incorrect.
(mscorlib) *

2020-09-11 15:45:01.30 ----- END OF TRANSACTION LOG COPY -----

Exit Status: 1 (Error)

Edit -- I forgot to mention that this part doesn't make much sense to me.

The first step is to configure permissions on the log backup folder so that the SQL Server Agent account on the secondary instance has access to the logs. The agent on the secondary instance will copy the logs from the folder that was designated as your log backup folder during the Transaction Log Backup Settings configuration.

If the Agent from the Secondary was able to access a folder on the Primary, this whole workaround wouldn't be needed.

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
8,499 questions
{count} votes

4 answers

Sort by: Most helpful
  1. Miamiao-MSFT 4,216 Reputation points
    2020-09-14T09:29:44.303+00:00

    Hi @chrisrdba ,

    Try to test with grant permission to everyone:
    24436-20190914test.jpg

    BR,
    Mia


    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Peter Babic 1 Reputation point
    2020-09-14T20:33:59.787+00:00

    Under which account are running your services for SQL agent service?


  3. Guoxiong 7,681 Reputation points
    2020-09-15T19:23:50.84+00:00

    Make sure that you changed the SQL Server Agent account in the "Log on as:" configuration to the service account you created: Box1Domain/ServiceAccount on box 1 and Box2Domain/ServiceAccount on box 2 and then restarted the SQL Server Agent service to make the changes.


  4. chrisrdba 276 Reputation points
    2020-09-16T19:18:57.223+00:00

    I got this working.

    I needed to RDP to the destination server w the account that the Agent is running under, and map a drive back to the source, specifying to connect as the account that the Agent there is using (yes, same name and pwd between them).

    I know this was suggested above but I didn't have the ability to do this until today. If another response should be marked as the answer that's fine w me.