RDS connection broker failing to connect to local WID

JustAnotherUser 36 Reputation points

We have a connection broker running Server 2019. It's been running for years. All of a sudden this weekend it started failing. It is reporting issues connecting to the database. In this case, we have a local WID setup, no high availability. The only change I can see is July Windows updates earlier in the week. This is not affecting RDP gatateway, only RDP published apps, they simply refuse to load. We restart the RDS gateway and it works for about a day then starts failing again. Is anyone else having the same or similar issue?

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
3,414 questions
{count} vote

4 answers

Sort by: Most helpful
  1. JustAnotherUser 36 Reputation points

    Actually, it's not what I expected. The RDS session is created at the gateway, user gets logged into one of the hosts in the host pool and the app starts running. I can see the user in task manager is active, the app is running but at the client, no connection is made and all the user can see is "RemoteApp" Starting your app and it hangs forever. It's as if the remote desktop software is failing to connect but the session is actually running.

    It looks like this may be something new with Windows 11 22H2. Several systems are now experiencing the same issue, all now running 22H2. I've tried the RDGClientTransport regsitry entry, that seemed to work on one PC but not the rest. Something seems broken in 22H2 with remote desktop apps. Is there a known resolution?

    0 comments No comments

  2. Oren Lahav 6 Reputation points

    i had the same problem, any thing i have try wasnt worked, event the registry key update didnt solved it.
    what i have done and manage to fix it, is to replace the files mstsc.exe and mstscax.dll in c:\windows\system32 folder, from a non updated windows 11 workstation.
    thats fix the problem in my case.

    0 comments No comments

  3. JustAnotherUser 36 Reputation points

    Windows 11 22H2 coming out September 20'th is totally broken with Microsoft Remote Desktop published apps, it does not work. Thanks for posting, replacing the broken remote desktop front end bits worked for me here too. Looks like Microsoft still needs to fix remote desktop quickly in 22H2 or they will have a lot of tickets to deal with on release day.

    0 comments No comments

  4. Brandon Chapman 121 Reputation points
    0 comments No comments