StreetAddress not showing in profileCardProperties

Mehta, Kapil - HMT 1 Reputation point
2022-08-12T13:55:31.257+00:00

Hi,

We have added the StreetAddress to Profile Card Properties as per the following command:

POST https://graph.microsoft.com/beta/organization/{organizationId}/settings/profileCardProperties

and confirmed the setting with a corresponding GET, as described at https://learn.microsoft.com/en-us/graph/api/organizationsettings-post-profilecardproperties?view=graph-rest-beta&tabs=http.

However, despite waiting many days, the Office 365 Profile Card is not showing the StreetAddress as a property. Could this be checked please, as we have different offices with similar floor numbers, so having the StreetAddress in the profile card is quite essential. We have the values for StreetAddress populated in user profiles.

Many thanks,

Kapil

Microsoft Graph
Microsoft Graph
A Microsoft programmability model that exposes REST APIs and client libraries to access data on Microsoft 365 services.
10,896 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Sheena-MSFT 1,731 Reputation points
    2022-08-12T14:24:59.737+00:00

    Hi @Mehta, Kapil - HMT ,

    According to this documentation, we have to pass StreetAddress in the request payloadwhile adding this to profile card. Please re verify this.

    POST https://graph.microsoft.com/beta/organization/{tenantid}/settings/profileCardProperties  
    Content-Type: application/json  
      
    {  
      "directoryPropertyName": "StreetAddress"  
    }  
    

    Also there is some limitation for the profile card customization :The profile card on which customization is allowed is currently only available for web apps such as Outlook Web App, OneDrive SharePoint, Office.com, etc. Check out this

    Note: APIs under the /beta version in Microsoft Graph are subject to change. Use of these APIs in production applications is not supported.

    Hope this helps.

    If the answer is helpful, please click Accept Answer and kindly upvote it. If you have any further questions about this answer, please click Comment.

    0 comments No comments