DNS Issue with windows 10 when Azure VPN is installed and network card reinstalled

MrFlinstone 476 Reputation points
2022-08-15T08:48:03.45+00:00

I have got a point to site azure VPN configured on my windows 10 device, and all along I have got custom DNS setup such that when the P2S VN is connected, dNS name resolution can work onto azure resources, and of course connection to the wider internet also works. Last week I was consistently experiencing slow internet connection speeds, tried several things to no avail and last option I had which was to uninstall the network cards (ethernet + wifi) and then reinstall then appears to have fixed my slow internet speeds, now getting circa 600mb, before it could barely fo pass 50mb.

In the process of uninstalling the network interfaces, I removed all the interfaces on the device, VPN, ethernet, wifi anything I could find under network adapters until there was nothing else. After the reinstallation of the wifi and NIC cards, I went on to install and configure the Azure VPN client that has always worked without issues. Now this is what I get.

Anytime the P2S VPN is loaded.
It comes up with the error, cannot find host or something like that.
I cannot browse the internet as DNS no longer works.

I see the warning message on system logs.

Name resolution for the name wpad timed out after none of the configured DNS servers responded.  
Name resolution for the name tsfe.trafficshaping.dsp.mp.microsoft.com timed out after none of the configured DNS servers responded.  

Prior to the DNS warning message, I get the entry below.

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID   
{8BC3F05E-D86B-11D0-A075-xxxxxxxxxxxxx}  
 and APPID   
{8BC3F05E-D86B-11D0-A075-xxxxxxxxxxxx}  
 to the user LAPTOP\User SID (S-1-5-21-1118145387-608033059-xxxxxxxxxxxxx) from address LocalHost (Using LRPC) running in the application container Microsoft.AzureVpn_2.1986.50.0_x64__8wekyb3d8bbwe SID (S-1-15-2-3059960481-3753488440-2049713862-xxxxxx-3066129221-xxxxxxxxxxxxxx). This security permission can be modified using the Component Services administrative tool.  

I am not sure if they are related.

What appears to be happening is that anytime Azure VPN configuration is loaded and the connection attempted, it fails to connect and then kills off DNS.
No amount of network reset fixes the issue.
The only fix is to restart

I am unsure as to what to do as this is making things very difficult for me, having to restart the laptop anytime I try to setup Azure VPN. I have a similar device, Azure VPN configured and it works fine on the second device without any issues.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,524 questions
Azure VPN Gateway
Azure VPN Gateway
An Azure service that enables the connection of on-premises networks to Azure through site-to-site virtual private networks.
1,360 questions
Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,266 questions
Windows DHCP
Windows DHCP
Windows: A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.DHCP: Dynamic Host Configuration Protocol (DHCP). A communications protocol that lets network administrators manage centrally and automate the assignment of Internet Protocol (IP) addresses in an organization's network.
1,021 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Limitless Technology 39,331 Reputation points
    2022-08-16T14:43:58.14+00:00

    Hello there,

    Point-to-site VPN client normally uses Azure DNS servers that are configured in the Azure virtual network. The Azure DNS servers take precedence over the local DNS servers that are configured in the client (unless the metric of the Ethernet interface is lower), so all DNS queries are sent to the Azure DNS servers. If the Azure DNS servers do not have the records for the local resources, the query fails.

    To resolve the problem, make sure that the Azure DNS servers that used on the Azure virtual network can resolve the DNS records for local resources. To do this, you can use DNS Forwarders or Conditional forwarders.

    The below thread discusses the same issue and you can try out some troubleshooting steps from this and see if that helps you to sort the Issue.
    https://learn.microsoft.com/en-us/answers/questions/39571/not-resolving-private-dns-zone-over-point-to-site.html
    https://learn.microsoft.com/en-us/answers/questions/64223/issue-with-resolving-hostnames-while-connected-to.html

    I hope this information helps. If you have any questions please let me know and I will be glad to help you out.

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept it as an answer--


  2. Cuddy, Ronald (C) 1 Reputation point
    2022-11-30T17:07:55.07+00:00

    We had to list the IP and FQDN of the Azure VPN gateway in the host file in c:\windows\system32\drivers\etc

    0 comments No comments