getting rule 56 on all of my network adapters

DSW325 1 Reputation point
2022-08-15T18:19:59.487+00:00

After a big thunderstorm my computer has been unable to access ethernet connection nor wifi. I checked my network adapters in Device management and they all give me a code 56, saying windows has not been able to set up class configuration. I do not have any vpns installed and I disconnected my VM adapters so that is not the issue. I tried using a USB Wi-Fi adapter, I downloaded the software and drivers and it still gave me the code 56. I tried re-installing windows but it keeps stopping halfway through giving me an error and booting me back to my desktop. the other computers in my house that use ethernet/WiFi work fine after replacing the router from Xfinity. Has anyone had this experience before?? I have tried a ton of different resets and nothing has solved it for my PC.

Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,282 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Dave Patrick 426.2K Reputation points MVP
    2022-08-15T18:22:53.593+00:00

    If it were an intel device there's a possible solution here.
    https://www.intel.com/content/www/us/en/support/articles/000038102/intel-nuc/intel-nuc-kits.html

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  2. Dave Patrick 426.2K Reputation points MVP
    2022-08-15T19:56:15.45+00:00

    when I try to reinstall the OS the reinstall stops halfway through

    How are you trying? The intel doc suggests a clean installation which means booting from the install media, delete / recreate partition and continue on with installation.

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  3. Limitless Technology 39,421 Reputation points
    2022-08-16T14:46:24.82+00:00

    Hello there,

    In some cases, the issue can be fixed simply by resetting the Bios.

    Try running the component tests
    -Hold the power button for at least five seconds to turn off the computer.
    -Turn on the computer and immediately press Esc repeatedly, about once every second. When the menu appears, press the F2 key.
    -On the main menu, click Component Tests.
    -The Component Tests' menu displays.
    Wireless Module Test - This test checks that the BIOS detects the wireless module and that it is enabled.

    ----------------------------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept it as an answer--

    0 comments No comments