question

DaveArnold-5570 avatar image
0 Votes"
DaveArnold-5570 asked DaveArnold-5570 commented

Installer Projects 2022 Extension Unrecoverable Build Error

Since upgrading Visual Studio Community 2022 to version 17.3, I am unable to build an installer project. The rest of the solution builds fine, but the installer project fails with:

Building file '...\Release\MyProjectName.msi'...
ERROR: Unrecoverable build error - 0x800700C1

It creates a .tmp file in the output directory before it fails, so I don't believe it is a permissions problem. I've tried running VS as administrator, but that doesn't help. I haven't been able to find any info on this error anywhere online.

Can anyone help with this? Thanks.

vs-generalvs-msbuildvs-extensions
· 6
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I've not noticed any problems with my installer projects when using the 17.3 preview builds.
Does this occur for all your installer projects, or just one/some?
Have you tried creating a new project as a sanity check?

0 Votes 0 ·

I only have the one solution, but I can try creating a new one to see what it does. Any idea what error 0x800700C1 means? The messaging doesn't really give me any hits to go on. Thanks.

0 Votes 0 ·

The VS Error Lookup tool says its: "%1 is not a valid Win32 application. "!
If a clean project produces the same error, perhaps a re-install of the extension is needed (though I've never had any such need).

0 Votes 0 ·
Show more comments

Hello, do you have any update? You can also try to repair your VS2022 through Visual Studio Installer > More > Repair. And check if the error goes away.
If the error only occurs in installer project, I suggest you report it to Microsoft Visual Studio Installer Projects 2022 team.


0 Votes 0 ·

I have tried repairing VS2022, but that did not help. I tried creating a new, clean solution with a new win forms project and a new installer project, and still get the same error:

Building file 'C:\Users\dave\source\repos\WinFormsApp1\Setup1\Debug\Setup1.msi'...
ERROR: Unrecoverable build error - 0x800700C1

0 Votes 0 ·

0 Answers