Remote Desktop Connection: Sound stopped working

Andrew-Joseph Magracia 1 Reputation point
2022-08-16T16:01:36.807+00:00

I've been working the past year by using Windows Remote Desktop Connection from my Windows 10 Home (OS build 19044.1889) to my work laptop, a Windows 10 Pro (OS build 19044.1645). However, recently my remote audio playback/recording have stopped working, and I have not changed my settings. That is: "Play on this computer" and "Record from this computer" are both selected, and the configuration file reflects this. I repeat: Remote playback and recording were working the entirety of the past year, and without a change in settings, they have stopped working. Nothing I do remedies this.

When viewing sound settings on my work laptop, I do see "Remote Audio" selected for both input and output. When playing sound on my work laptop, e.g. a YouTube video, or a conference call, I can see the sound visualization moving on the Master volume bar in sound settings, as expected. However, nothing reaches my local machine. Also, when accessing Microsoft Teams on my work computer, I see "Remote Audio" for both Speaker and Microphone; however, when making a test call, I hear nothing, and Teams also states it cannot find my microphone. However, my webcam, which is also plugged into my local machine, like my microphone and speakers, works fine.

Any assistance would be appreciated.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,382 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Philippe Levesque 5,706 Reputation points
    2022-08-16T17:18:15.733+00:00

    In your RDP setting, inside the work laptop, did the audio options got changed ? I ask as a admin might have changed a policy that impacted your laptop.

    Go there to see;

    • Open Group Policy editor; (run -> gpedits.msc)
    • Go to Computer Configuration, Administrative Templates, Windows Components, Remote Desktop Session Host, Device and Resource Redirection;
    • Set Allow audio and video playback redirection to "Enabled"
    • I would add that too; for the quality;
    • Set Limit audio playback quality” to “Enabled”
    • Set “Audio Quality” option “to High”
    2 people found this answer helpful.