Update is not installing during maintenance window

lalajee 1,811 Reputation points
2022-08-17T12:11:04.607+00:00

Hi,

I push Aug 2022 updates to our servers but for some reason the "Windows Malicious software removal tool x64" is not installing during the maintenance window all other updates got installed without any problem

Update deadline was 13 Aug 2022
Maintenance Window for these 300 machine is

  • Everyday between 1am to 4am
  • Every 2nd Saturday in Monday 7am to 7am

Update is showing in Software center
I run the report and I can see MW set for this machine
When I look at the log file UpdateDevelopment it say "No Service window available to run update assigment" at 1am

Microsoft Configuration Manager Updates
Microsoft Configuration Manager Updates
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Updates: Broadly released fixes addressing specific issue(s) or related bug(s). Updates may also include new or modified features (i.e. changing default behavior).
978 questions
{count} votes

2 answers

Sort by: Most helpful
  1. lalajee 1,811 Reputation points
    2022-08-17T13:09:10.36+00:00

    When I build this MECM Server I change the Software Update Point Component Properties

    Maximum Run Time Tab
    Maximum run time for Windows feature update from 120 minutes to 360 minutes

    I'm not sure why but the "Windows Malicious software removal tool x64" max run time is set to 360 minutes.

    "Windows Malicious software removal tool x64" is not feature update so why has MS set the time on this update to 360

    Can someone please explain this, is this bug in new mecm or did i do anything wrong

    0 comments No comments

  2. Amandayou-MSFT 11,051 Reputation points
    2022-08-18T09:14:38.49+00:00

    Hi,

    "Windows Malicious software removal tool x64" is not feature update so why has MS set the time on this update to 360

    Yes, They are irrelevant. First we should notice the update is required by these clients, check if there is Missing record in UpdatesStore.log, maybe it is not required and not install.


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.