Azure Files backup policy dont work

Florian Bartsch 11 Reputation points
2022-08-17T22:13:36.61+00:00

Hey guys,

I mounted an azure file storage to azure kubernetes and wanna backup it every day.

But for some reason the backup policy dont trigger.

Also tried to follow this instruction step by step, deleted everything and recreated it, checked region of all components.... it just will not backup the storage file.

https://learn.microsoft.com/en-us/azure/backup/backup-afs

There are no errors or warning. Just an advice that he's waiting for the first backup.

Any ideas?

Thanks

Azure Backup
Azure Backup
An Azure backup service that provides built-in management at scale.
1,142 questions
Azure Files
Azure Files
An Azure service that offers file shares in the cloud.
1,186 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Florian Bartsch 11 Reputation points
    2022-08-18T21:35:06.507+00:00

    Hey Manu,
    thanks for your advice.

    This issue is solved by itself. It just took some hours to run for some reason.

    Ive set the backup time to 11pm german time and it did start at about 2am.

    Now ive set the policy to coordinated universal time 9pm and it started today at 11pm german time.

    Super weird but worked. =/

    Thanks a lot.

    2 people found this answer helpful.

  2. Manu Philip 16,991 Reputation points MVP
    2022-08-18T03:47:25.727+00:00

    Have you checked if a manual backup is working or not?
    Visit 'Backup Center' and initiate a manual backup
    Also, check if the policies and the schedules are correctly configured under Backup Policies section

    Hope, you are following the support matrix also as indicated here: azure-file-share-support-matrix

    ----------

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    0 comments No comments