Hyper-V TPM not working

Limer324 11 Reputation points
2022-08-23T14:28:03.02+00:00

Hi there TechNet, I've been having some severe trouble with the virtual TPM function of Hyper-V. Now, my Windows 11 VM (a brand new one) refuses to start up if the TPM is enabled in the VM's Security settings (no matter if the encryption option is on or off). I find this so weird because this option used to work without any issue, and I have no clue what has changed that it doesn't like. I'd need this solved as TPM is a requirement even for virtualized Windows 11, which will be needed for future Insider updates.

For extra context, I have Guarded Host, all Hyper-V services, Memory Integrity, and Secure Boot all turned on within the host machine, which runs Windows 10 Pro. (Windows Security says my device meets the requirements for enhanced hardware security) Of course, I have a TPM 2.0 chip as well. Again, it's most likely not a hardware issue, as it used to work just fine before, and I haven't changed the host's hardware in any meaningful way. It's probably a software/firmware issue.
234060-vm-startup-error.png

System Center Virtual Machine Manager
Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,530 questions
0 comments No comments
{count} vote

3 answers

Sort by: Most helpful
  1. Michael Taylor 47,716 Reputation points
    2022-08-23T15:15:26.323+00:00

    I've not seen that error before but the nested error message indicates it cannot find a file, not that something isn't enabled. It makes me believe that perhaps your VM is either not properly registered with Hyper-V, you have cloned a VM and didn't change the IDs so it is getting confused or your VM references a HDD or some other file that it can no longer find.

    I think you should verify that your VM files are all in the right spots, that Hyper-V can find them and if necessary run Process Monitor to see what file(s) it cannot find.


  2. Limer324 11 Reputation points
    2022-08-24T22:03:08.497+00:00

    Now, I decided to take the easiest way out of that and reinstall all of Windows, and I fresh installed Windows 11 Pro. Then I created a brand new virtual machine in a brand new Hyper-V, the exact same error again.

    I am literally 100% out of ideas what I could do here. Maybe turning on VBS could help?


  3. Gordon McCague 0 Reputation points
    2023-02-12T01:33:35.2533333+00:00

    I was wrong.

    0 comments No comments