AzureDevOps Build is Not Compiling DLLs

ISAAC ORTIZ 1 Reputation point

With XAML builds you could add the following argument /p:GenerateProjectSpecificOutputFolder=True and it would cleanly build your code and compile your dlls per library. With YAML builds however, this argument does not appear to work and all the code comes out uncompiled with *.vb files. My solution has a mix of class, web, and console apps. Any recommendations on getting it to properly build? Many thanks!

Azure App Services
Azure App Services
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,561 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Piyush Mutha 11 Reputation points

    Please try to check the “Build Action” property of that .vb file. It should be “Compile”.

    1. Right click the .vb file in Solution Explorer, and then select “Properties”.
    2. Select “Compile” option of the “Build Action” property in Properties panel.
    3. Rebuild you project and test again.

  2. StingyJack 116 Reputation points

    You should enable the system.debug == true variable and check the "Enable System Diagnostics" for a build, run the build, and then inspect the logs for it. The actual msbuild.exe command that is executed will be in there, with all the parameters its using.

    Clean all of the bin and obj folders in your solution, and then take the command from the build log and and try running it locally to see if you get output.

    Chances are that you will see the same as the build agent is seeing, and have probably not named the correct solution configuration (Debug, Release) or something simple like that.

    If you didnt find an msbuild command in the logs then you have to fix the build definition to add it. Try creating a new build definition using the Task based engine and not the YAML way. YAML builds are newer and probably a bit buggy.