Hybrid Azure AD Joined (connection loss)

Blindf8th 61 Reputation points
2022-08-26T17:10:31.54+00:00

Good afternoon,

Recently we have seen several devices out of no where lose the connection to our Azure tenant (Windows > Settings> Accounts > Access work or school. The only thing we do see is the Connected to AD Domain.

Nothing has changed with these devices that we are aware of. When we check dsregcmd /status we see that all these devices have AzureAdPrt : YES with a couple that show AzureAdPrt : NO.

These devices are also all registered with AutoPilot which means leveraging the dsregcmd tool to leave/join the organizational tenant is not possible because Azure prevents the deletion of these devices. If click the + to add it we receive an error that states "Your device is already connected to your organization" & "Your device is already being managed by an organization". The main thing impacted at this time is the access to the Company Portal (it errors out).

Azure Device Check:
Join Type: Hybrid Azure AD joined
Enabled: Yes
MDM: Microsoft Intune
Compliant: Yes

Endpoint Check:
Managed by: Intune
Ownership: Corporate
Compliance: Compliant
Last check-in: Updates daily

Two questions:

  1. Any idea what can cause this behavior?
  2. How can we re-add the Connected to company Azure AD?

Any information or thoughts would be greatly appreciated.

Thanks,

Blind

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,396 questions
{count} votes