Storage Space 0x00000002 error: cannot add new drives to pool

Moro 41 Reputation points


I have a SP composed by 11 disks of various size, from 3TB to 8TB. A single partition with Dual Parity is hosted on these disks. All are connected through USB 3.1. I tried to add the 12th disk however I receive the following error:

Can't prepare drives
Close all applications that accessing the drive, and then try again
The system cannot find the file specified.

As a single disk I can initialize it as GPT and format it and use it. No errors on SMART report as well as on the drive writing and reading files.

OS is Windows 10 21H2.

Any idea is appreciate.

Windows Server Storage
Windows Server Storage
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Storage: The hardware and software system used to retain data for subsequent retrieval.
609 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Xu Gu (Shanghai Wicresoft Co,.Ltd.) 496 Reputation points

    Hi Moro,

    Based on your description, I'll analyze it from the error code: 0x00000002 and "cannot not add new drives to pool":

    1. You can repair the operation by resetting the failed disk, if there is important data on the disk that needs to be reset, it is best to back it up before resetting. The steps are as follows:
      (1) Open PowerShell as an administrator and enter the following command:
      Get some information about the physical disk: Get-PhysicalDisk | ft FriendlyName,SerialNumber,UniqueId -auto
      (2) Reset the problematic disk via FriendlyName or UniqueId:
      Reset-PhysicalDisk - FriendlyName xxx
      Reset-PhysicalDisk -UniqueId xxx
      (3) Restart the machine, and then try to attach the disk to the SP again.
    2. Restart the computer. There may be some background apps that are using the storage pool or disk you're trying to add. Therefore, it may prevent you from adding more drives to the storage pool or adding disks to the storage pool.
    3. You can also try attaching a disk in safe mode. Then try attaching the disk to the SP. The steps to turn on Safe Mode are as follows:

    Best Regards,
    Xu Gu

    0 comments No comments

  2. Moro 41 Reputation points

    Hi @Xu Gu (Shanghai Wicresoft Co,.Ltd.) ,

    is the commamd executed on the disk or on the computer OS? I mean, can I run the commamd on another computer with my problematic hard disk connected to it and the reconnect the hdd to the pc where the StorageSpace reaides?
    I want to avoid to launch such commamds on my SP computer to avoid errors and the cobsequent SP failure...

  3. Moro 41 Reputation points

    Hi, it seems that the problem was not the physical disk but a single USB enclosure. Adding drives from it caused the error. I inserted the drive into a 5 disk USB chassis and Storage Space added it immediately.

    0 comments No comments