Sp core library 1.1.0 is used in existing project

Patil, Amar Vishnu (Cognizant) 1 Reputation point
2022-08-28T21:14:26.767+00:00

Hello,

Existing project is using spfx 1.1.0 version, when trying to install node modules the project is not getting build.
Should I upgrade it to latest node version or which node version to be used to build it.
If in case I need to upgrade it what are the steps to do it?

Please help..

Thanks!!!

SharePoint Server Development
SharePoint Server Development
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Development: The process of researching, productizing, and refining new or existing technologies.
1,569 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Tong Zhang_MSFT 9,116 Reputation points
    2022-08-29T03:33:19.347+00:00

    Hi @Anonymous ,

    According to my research, if you using the SPFx v1.1.0, you should install node.js v6.

    Please refer to this document: SPFx development environment compatibility

    If you want to upgrade the SPFx version, you can select the required version to install in the documentation above.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.