Error connecting AKS with ACR

Kopl 166 Reputation points
2022-08-30T11:33:12.563+00:00

Hello team,

My AKS was connected to ACR for months now and I was always able to pull images from ACR. However, this morning I am not able for some reason.

I tried using this command:

az aks update -n myAKSCluster -g myResourceGroup --attach-acr <acr-name>

However, without success. Could you please help?

Azure Container Registry
Azure Container Registry
An Azure service that provides a registry of Docker and Open Container Initiative images.
403 questions
Azure Kubernetes Service (AKS)
Azure Kubernetes Service (AKS)
An Azure service that provides serverless Kubernetes, an integrated continuous integration and continuous delivery experience, and enterprise-grade security and governance.
1,892 questions
{count} vote

12 answers

Sort by: Most helpful
  1. Kopl 166 Reputation points
    2022-08-30T11:41:03.287+00:00

    Here is the error message I am getting in kubectl describe pod:

    Failed to pull image "registryname.azurecr.io/repositoryname:latest": rpc error: code = Unknown desc = failed to pull and unpack image "registryname.azurecr.io/repositoryname:latest": failed to resolve reference "registryname.azurecr.io/repositoryname:latest": failed to do request: Head "https://registryname.azurecr.io/v2/repositoryname/manifests/latest": dial tcp: lookup registryname.azurecr.io on [::1]:53: read udp [::1]:48079->[::1]:53: read: connection refused

    Thank you for your help!

    1 person found this answer helpful.

  2. Marco Kruger 6 Reputation points
    2022-08-31T07:05:46.35+00:00

    Having the same issue, started yesterday about half-way through and is impacting all of our environments.

    1 person found this answer helpful.

  3. Pascal Vreeburg 6 Reputation points
    2022-08-31T08:56:37.91+00:00

    We are also experiencing the same Issue in Western Europe. When I try the update command:

    az aks update -n clustername -g resourcegroup --attach-acr [acrname] --debug

    I get an error message specifying that the provided [acr name] is not part of the same subscription as the cluster and resourcegroup. Which is indeed the case, but this setup did work previously without any issue.

    1 person found this answer helpful.
    0 comments No comments

  4. Nadav Ben Haim 501 Reputation points Microsoft Employee
    2022-08-30T13:03:59.317+00:00

    Hi,
    Unfortunately I dont have any ETA for this, just that it's being handled by us.
    Let us know once the issue was mitigated if your issue with connecting to the ACR was also mitigated.
    If it was, please accept my answer and we will archive this question.

    0 comments No comments

  5. Sean Hannan 1 Reputation point
    2022-08-31T05:40:01.61+00:00

    @Nadav Ben Haim We are also experiencing the same issue as above with same symptoms fine for weeks since last deployment - now getting "Failed to Pull Image" errors. Ran the command as requested above and can see no errors. Have tried redeploying image before finding this issue report.

    Is this an issue with AKS ?